Remove default extension in Style Configurator



  • I’d like to open *.S files as if they are Assembly files (same as *.asm).

    I can add “S” to “Assembly” in the style configuration user defined extensions. But, I cannot remove the current mapping for “S” which is assigned to the “R” language.

    Therefore, “S” files will always be opened as if they are “R” language files.

    How do I remove “S” file types from the “R” language parser?



  • Didn’t try it by myself but my guess is:
    Settings --> Preferences --> Language Menu
    Move ‘R’ to disabled.



  • You have to edit the file

    C:\Users\<UserName>\AppData\Roaming\Notepad++\langs.xml

    Search the following Language node:

    <Language name="r" ext="r s splus" commentLine="#">
    

    You have to remove the s in the value of the attribute ext.



  • Thanks, this worked. maybe the GUI setting could allow this in the future.


Log in to reply