Removing Words From Auto-Completion



  • I took a look around and found that there seems to be suggestions in my auto-completion that don’t match the documents I’m typing. Specifically “pubdate” when the entire document uses “pubDate”. Tiny difference, but when I’m in the groove and sometimes I use the first one (which, if used, will render the whole document useless until fixed).

    Is there any particular way to remove certain words from the auto-complete or is it there forever?



  • @Shelby-Copeland

    Are you SURE you don’t have a pubdate in your file somewhere (try using N++ search function for its exact case?)? I tried to test this by mocking something up, putting in some pubdate and pubDate and trying auto-completion. I found that if both variants exist somewhere in the file, both will be in the auto-complete suggestion list, but immediately after I remove the last of either variant and then start typing pub… again, only the variant still existing appears as a suggestion.



  • pubdate search, forward and backward, match case.

    Count: 0 matches

    I know what you mean, and checked before posting to make sure. Then after you replied I checked again. “pubdate” just isn’t there, but for some reason is still suggested. I thought maybe it was in another file I made, so I thought to check those too. No hits. But for some strange reason the suggestion is still there. And it won’t go away T_T



  • @Shelby-Copeland

    I assume you know that you can have Function, Word, or Function and Word completion enabled. Have you tried playing with these settings to see if you can learn anything more about the behavior you are seeing?



  • As a function, the lowercase one appears. As just a word the uppercase one appears even when used as a function. These settings I haven’t changed ever until now and there was still a point where I didn’t have this problem.

    Now even if we solve that issue by switching the auto-comp to word-only, there are still other words I’d like removed for the sake of an easier flow in writing so I’d still be hoping for a solution to the general question rather than the word used.



  • @Shelby-Copeland

    So, if “pubupdate” is NOT in your file, but it appears when function completion is enabled, it means that you have a language-specific file (an XML file in the plugins\APIs directory) that contains “pubupdate” as a function name or keyword. All the function names and keywords in that file will pop up as a possible auto-completion when you start typing enough of one, whether they already appear in the file or not.

    If you find this to be the case, you could always edit the XML file to remove functions or keywords that you don’t want to pop up in the auto-complete list.



  • Okay cool. Problem with that is…I did it once, but then I forgot how. T_T I’ve been looking for it for so long that I became convinced that maybe I didn’t. How do I get access to that list of functions and keywords?



  • @Shelby-Copeland said:

    How do I get access to that list of functions and keywords?

    I think Jim already told you:

    @Jim-Dailey said:

    an XML file in the plugins\APIs directory



  • ALrighty then. I’ll go hunt that down and everything should be smooth sailing. Thanks for the help guys.



  • @Shelby-Copeland

    I can’t tell if that last reply of yours was dripping with sarcasm or not. :-)

    It would certainly be easy enough to pull one of the files from ...\plugins\APIs into Notepad++ and then do a Find in Files on it (of course you have Follow current doc. checkbox ticked, right?), looking for the exact-case version of pubupdate

    Please post again if this technique doesn’t solve your problem, and we’ll what else can be done.


Log in to reply