Unneccesary Characters in .Out file



  • Hi Every One,
    I am Need of working with .Out file Extension but while opening file in notepad ++ it is showing me unnecessary characters (Letters are highlighted) in file, I tried in Langauage Tab but no use, could any body please help me to get rid of from this…

    Note: I am not seeing this issues in normal notepad. Please help me

    Thanks in Advance.



  • @Thirupathireddy-V

    Perhaps a screenshot of what you are seeing will help. See here (the last part of it) for how to post one.



  • I am unable to post screenshot , could you please help me on this.



  • @Thirupathireddy-V ,

    The “?” of the little grey “COMPOSE ?” in the upper right of the post-editing window would take you to help for formatting (which includes how to embed an image)

    But I find that @Scott-Sumner’s help-with-markdown post is a much better introduction to the concepts. If you don’t have a tool to grab the screenshot – you do. In Windows, Alt-PrintScreen will grab a screenshot of the current window; you can then open mspaint.exe from the Win+R run menu; save it. In Windows 10, an alternative is the Snipping Tool: click on the Windows button on your taskbar, and type “Snipping”, then click “New”, then drag a box around the portion of your screen you want to snip; then save it. Once you have an image, you can upload to a free image-sharing site, like imgur.com – you don’t even need a login; then grab the URL to the image (in imgur, click on the image, then copy the Direct Link or Markdown Link) and embed it in the forum using code like ![Imgur](https://i.imgur.com/0Mon4gO.png) (if you grabbed the Markdown Link, you just need to add the exclamation point ! immediately before the copied link text) – this embedding technique is described in Scott’s help-with-markdown post.

    A screenshot will be useful to confirm… but as a guess:

    Given that you said it’s “showing me unnecessary characters (letters are highlighted)”, I am assuming you are seeing some letters that are smaller than others with a background; some of the letters I would guess you are seeing are CR and/or LF at the end of lines.

    I don’t know what the .out file is (other than a.out from a linux compiler… and if you’re trying to read that with a text editor, you really don’t understand what you’re doing – see #2 below), so I don’t know whether it’s a binary or partially-binary format, but if it is, there may be many other binary characters, which may show up as other 2-3 letter sets in the same background-box, such as NULL, SOH, STX, … All of those are indicative of non-textual data in the file you are looking at.

    If this is what you’re seeing, then either

    1. If it is a plaintext (or mostly plaintext) file, then you probably have a Show Symbol option turned on. Go to View menu > Show Symbol: one of “Show End of Line” or “Show All Characters” is probably enabled. If it is enabled, click on the selected option again to turn it off.

    2. It’s primarily a binary file, which means that some or most of the information in the file is encoded (or compressed or encrypted) in some way other than text. Notepad++ is a text editor. It will show you any text that happens to be unencoded (or any encoded data that happens to look like text, but isn’t really), but it’s not built to decode arbitrary data. Some more information can be found in this FAQ Desk post (which focuses on PDF and DOCX, but conceptually applies to any binary-encoded file, whether it’s a word processing file, a database or other data file, an image, or an executable or library file, or anything else that’s not a plain-text file)

    But again, the best confirmation will be a screenshot.


Log in to reply