XMLTools 2.4.9.2 64-bit not compatible with Notepad++ 7.5.9 64-bit



  • After following instructions for XML Tools 2.4.9.2 x64, I get a message that the plug-in is not compatible with this version.

    Notepad++ v7.5.9 (64-bit)
    Build time : Oct 14 2018 - 15:19:55
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS : Windows 7 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll

    Is there a way to correct this issue?



  • Maybe you what to use https://github.com/bruderstein/nppPluginManager/releases/tag/v1.4.12 for automatic installation. For me it is working. Otherwise you could check https://github.com/bruderstein/npp-plugins-x64/blob/master/plugins/plugins64.xml#L1228 how it is installed and redo the steps manually.

    		<download>https://sourceforge.net/projects/npp-plugins/files/XML%20Tools/Xml%20Tools%202.4.9%20Unicode/Xml%20Tools%202.4.9.2%20x64%20Unicode.zip/download</download>
    			<copy from="dependencies\libiconv-2.dll" to="$NPPDIR$\" validate="true"/>
    			<copy from="dependencies\libwinpthread-1.dll" to="$NPPDIR$\" validate="true"/>
    			<copy from="dependencies\libxml2-2.dll" to="$NPPDIR$\" validate="true"/>
    			<copy from="dependencies\libxslt-1.dll" to="$NPPDIR$\" validate="true"/>
    			<copy from="dependencies\zlib1.dll" to="$NPPDIR$\" validate="true"/>
    			<copy from="install.txt" to="$PLUGINDIR$\doc\XmlTools"/>
    			<copy from="XMLTools.dll" to="$PLUGINDIR$\" validate="true"/>
    			<copy from="dependencies\libcurl.dll" to="$NPPDIR$\" validate="true"/>

Log in to reply