File Type issue



  • Windows 7 64 bit
    Notepad++ v7.5.8 64 bit

    When I updated to this newer version of NPP, I was having several file association issues. First, NPP wasn’t showing up in the Right-click>Open With>Choose Default Program menu, even when I browsed for the file location. Fixed this with a registry edit, as suggested by user “T Q” here.

    Now I have a different problem. With some file types (including .txt), when I go Right-click>Open With>Choose Default Program, it gives me the option to select NPP. I select it and check the “Always use this program” box. Then when I look in Windows explorer, it shows the file type for all my .txt documents as “Notepad++ Document” instead of “.txt file” or something.

    So if I have this same problem for multiple file types in the same directory, I can’t effectively sort the directory by file type because Windows doesn’t distinguish between .txt and .othertype, it thinks they are all the same kind: a “Notepad++ Document”



  • You are using Windows 10 1803? There seems to be a bug introduced with the 2018-10 Windows updates, see here.



  • @dinkumoil See first line, seems to be Win7. Maybe some similar bugfix update from MS which was applied also to win7, if this was ever working in the past.



  • @Jeffrey-Snively and all,
    IMO this is by design. Associating a file with a particular application in Windows allows one to double click on that file and have it open with the associated application. In the Explorer window the column is called “Type”, not “file extension” because that’s what it is, showing files by type (default application).

    This is a double edged sword. You can’t have one without the other.

    Terry



  • @Jeffrey Snively

    When I updated to this newer version of NPP, I was having several file association issues. First, NPP wasn’t showing up in the Right-click>Open With>Choose Default Program menu, even when I browsed for the file location. Fixed this with a registry edit, as suggested by user “T Q” here.

    This issue is now fixed in one of my PRs. Hope, that will be accepted and merged in upcoming release.

    About other concern related to sorting. This is as designed by windows. If you really want to short then, you can enable one more column called “File Extension” along with “Type”. Then you can sort using “File Extension” instead of “Type”.