Double Click On Any Txt File Defaults To new1.txt in Standard User account - why??



  • System: Windows 7 Home Premium SP 1, 64 bit

    This is strange. Problem started when I upgraded notepad++ from version 7.5.9 and to version 7.6. When I double click on a txt file, no matter what the file name, notepad++ opens with an empty file named “new1.txt”. Thus the file I clicked may have the name hello.txt and have lots of text in the file, but when I double click the file, notepad++ opens with a blank file “new1.txt”.

    Note that I have two accounts - an Administrator account & a Standard User account. Double clicking on a txt file in the Administrator account works correctly - notepad++ opens with that file.!! But this does NOT work in the Standard user account – just opens with blank file new1.txt.

    If I right click on a txt file in the Standard User account & select “Edit with notepad++”, this works fine - notepad++ opens with that file.

    If I right click the file hello.txt & choose Open with --> Notepad++, notepad++ again opens with the blank new1.txt. But only in the Standard User account. In the Administrator account, this right click works correctly - notepad++ opens with that file.

    txt file extension is correctly associated with notepad++ in both accounts.

    Below is what I did to try and fix the problem (nothing worked):
    (1) Uninstalled version 7.6 and installed 7.5.6. Also tried reinstalling version 7.5.6 three times.
    (2) Ensure that: assoc txt=txtfile & ftype txtfile=“C:\Program Files (x86)\Notepad++\notepad++.exe”
    (3) Ensure that in notepad++, Settings ==> Preferences ==> Misc that the field “Session file ext” is blank.

    What I may try next: Uninstall notepad++; create restore point; delete all references to notepad++ in the registry; reinstall notepad++ 7.5.6. I don’t have high hopes that this will work, but maybe worth a try.

    Any suggestions???



  • CORRECTION – The problem discussed above occurs in BOTH the Administrator and Standard User accounts.

    How to fix???


Log in to reply