Notepad++ 7.6 autoupdate disable



  • Hello

    During installation of 7.6 you cannot de-select autoupdate:(.
    If I remove updater folder from installation folder you cannot see “Update Notepad” anymore under ? menu. Is this proper way to disable auto update?



  • @Aku-Suonpää

    the proper way to disable auto update is:
    settings > preferences > misc. >>> uncheck “enable notepad++ auto updater”



  • Auto Update is “grayed out” by the installer because it’s a dependency of Plugin Admin. You must uncheck Plugin Admin first to change it.

    There’s a pitfall the other way around, too: If Auto Update was deselected during a previous installation and you update to 7.6, Plugin Admin is installed without its dependency and won’t show up in the menu. >:-)



  • This is very sad because we don’t want to update Notepad++ automatically, but we would like to use plugins:(



  • @Aku-Suonpää

    didn’t you read my post above how to disable auto update ?

    YOU CAN DISABLE AUTO UPDATE AND USE PLUGINS AT THE SAME TIME

    just go to: settings > preferences > misc.
    and uncheck “enable notepad++ auto updater”



  • @Aku-Suonpää

    i guess i think i know where your missunderstanding regarding auto updates comes from:

    you have to install with plugins manager and auto updater.
    but the word “auto updater” at the time of installation confuses you.
    if it just would be called “updater” it would be clearer, as it is just the program to update np++ and the plugins, the auto update is an extra setting within the misc. options.

    correct ?



  • Disabling automatic updating from misc is good enough.

    Any chance to have possibility modify that setting for every user on windows computer? Like some kind default settings file in install folder what will be used as default when new user starts Notepad++ first time. Also possibility to override user settings would be cool.

    Now I have to do active setup tricks to disable auto update from users.



  • @Aku-Suonpää

    yes, you can create custom default settings for every user and future user:

    first open notepad++ and make all custom settings you need.
    then close notepad++ (important, the config will only be saved on exit)

    open %APPDATA%\Notepad++ in explorer
    copy the file config.xml to %ProgramFiles%\Notepad++
    (note: the path is %ProgramFiles(x86)%\Notepad++ for the 32 bit version)
    and rename it to config.model.xml

    from now on all new config.xml files will be created using your personal config.model.xml template

    if you already have existing default config.xml files in %APPDATA%\Notepad++ of existing users, just delete them all, they will be recreated using your template.



  • excellent thank you



  • you’re welcome, @Aku-Suonpää

    regarding:

    Also possibility to override user settings would be cool.

    the only (dirty) workaround i can come up with, is to regularly delete the users config.xml, so they will be recreated from your template.

    this could either be done by a custom shortcut for notepad++.exe that deletes %APPDATA%\Notepad++\config.xml before starting notepad++.exe, or a startup script/batch, so that the config will be “reset” at every boot



  • @Meta-Chuh "just go to: settings > preferences > misc. and uncheck “enable notepad++ auto updater”

    You are assuming this works all the time, and it doesn’t. It has never worked reliably for me. For example, 5 minutes ago I launched NP++ and I was prompted if I want to update, yet I have auto updater unchecked. That’s why I did a web search and ended up on this page: to try to find a way that actually works.



  • @mtnrunner2

    I could imagine that this happens when the config.xml is corrupted.



  • @mtnrunner2

    yes, you are correct.

    there is currently a bug #5375 with the auto updater.

    workaround by ChliHug until it gets fixed:
    change the nextUpdateDate value in config.xml to the next millennium. nextUpdateDate=“30000101” for example.

    sorry for the inconvenience.



  • OT: I see that the above posting by @Meta-Chuh is his most-recent, and that was 16 days ago, and he wasn’t very active (like his usual) for a decent period leading up to that. Is he just on an extended AFK period, or has his interest in N++ waned…anyone know? His contributions were always extremely valuable…



  • @Alan-Kilborn

    I see he is reading from time to time but you are right @Meta-Chuh is very silent at the moment. At github as well.
    Hope it is just some … let’s get some rest … and he is fine.



  • @Alan-Kilborn said:

    anyone know?

    I’m not sure. He hasn’t responded to my e-mails for more than a month, either.

    I’m hoping that this is just a long, mostly-away-from-computers summer vacation that he’s taking, and that he’ll be back soon (or at least, by this fall). If not, it’s yet another loss to this Community and Notepad++ in general.



  • @Meta-Chuh said in Notepad++ 7.6 autoupdate disable:

    change the nextUpdateDate value in config.xml to the next millennium. nextUpdateDate=“30000101” for example

    Thanks for the workaround! It worked for me 🙂


Log in to reply