What's triggering "move to other view" cursor?



  • I’ve used NPP happily for years and remain a beginner with no need for the bells & whistles that other IDEs put in my face. My only complaint is lost time and distraction due to something that happens in response to ?a movement of the mouse? I don’t know why but this happens regularly. My mouse cursor turns into a cursor that says “move to other view” and “clone to other view”. ESC doesn’t turn it off, right-clicking doesn’t turn it off. So I don’t know where it comes from and I can only get rid of it by choosing one of two options that I don’t want. Since this command is available on the View menu or the right-click context menu when clicking a tab, I’d like to turn this auto-behavior off. I’ve searched NPP docs for mouse gesture and looked at the wiki but since I don’t know why this is happening I don’t know where else to look. Thanks if anyone can help make this stop. I’m using NPP v7.4.2.



  • @Scott-Robertson
    These 2 options exist in the “shortcut mapper”, under settings menu. In my version they are numbers 146 and 147. See if you have assigned any shortcuts for them. Selecting them may also identify if there are conflicts with any other commands.

    Possibly, if they have assignments, remove the assignments and see if your problem clears up.

    Terry



  • Thanks. The shortcut mapper was my first stop but there are no shortcuts to delete. I think this happens when I’m doing something with my mouse, not keys.



  • @Scott-Robertson
    Another suggestion is to swap-out your mouse. I’d say it doesn’t make sense to have either the left click or right click on the mouse do those tasks (I’m not sure you could even assign them in NPP) as you need the mouse for basic selection and context sensitive menu’s (as you mentioned).

    So it might be that the buttons have become hypersensitive and any movement is activating them. Do you have a basic mouse or one that has programmable buttons such as used in First Person Shooter type games? If the latter, have you assigned anything to them for other applications, and if so is that interacting with NPP in the way you describe.

    I’d suggest even swapping out the keyboard in case maybe some fluff is affecting the keys. Another option, but a bit drastic is clearing out the configuration files for NPP. I don’t have the details to hand but there are other posts on this forum on how to do so. Lastly, since you have an old version, remove it (if as you say you have no additional plugins etc installed), clear out all folders for the old installation and install the latest version.

    Terry



  • Found it. This is triggered by clicking a tab and dragging the mouse down while holding the mouse button down. To get rid of it just click the tab and the unwanted little popup menu disappears. Not a big deal now that I know why it’s happening and how to cancel the popup. Thanks for responding.



  • @Scott-Robertson
    Thank you for updating the situation. Now I also know something new about NPP.

    Terry


Log in to reply