Cannot get Compare plugin to load

    1. I first tried it on version 7.0, that produced a warning every time I opened Notepadd++ about it being incompatible version or something of the sorts. I then used the installer for 64 bit v7.6, then used the installer (and uninstalled 64 bit) to install the 32 bit (I read elsewhere that there were issues with the 64 bit and some things).
    2. I’m guessing that I didn’t use that option, because I don’t remember seeing or looking for it.
    3. Yes I’m normally on a regular user account and have to accept admin usage to install.

  • Read this thread, there I’ve posted a solution for your problem.

  • @dinkumoil This solution did not work for me. I still cannot get the compare plugin to show up.

  • @Jason-JI9QD said:

    This solution did not work for me. I still cannot get the compare plugin to show up.

    Please provide precise information about what you exactly did. Further more provide the Notepad++ debug informations obtainable under (menu) ? -> Debug Info.

  • Compare also does not load for me anymore since the new update. Have tried to install via the Plugin Admin option and also by downloading the dll online and copying it into the Pgms 86 notepad ++ folder. Was working perfectly up until the update. Very frustrating.

  • Debug info of current installation:
    Notepad++ v7.6 (64-bit)
    Build time : Nov 13 2018 - 00:12:05
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll

    One clarification to earlier, I don’t actually have to log in as admin on this computer to install things, I only need to verify admin rights by a yes click on a popup.

    I have downloaded the compare plugin from the website. I placed it manually into:
    C:\Users\USER\AppData\Roaming\Notepad++\plugins\config, restarted Notepad++, no success

    I then put the .dll into:
    C:\Users\USER\AppData\Roaming\Notepad++\plugins\config\ComparePlugin, restarted notepad++, no success.

    I did the same with C:\Users\Administrator\AppData\Roaming\Notepad++\plugins\config, no success

    I also tried from the Notepad++ menu. Settings>Import>Import Plugins, selected the .dll, restarted notepad++, no success
    I also tried this running N++ as administrator.

    I tried the Plugin Admin, selected Compare tool, hit install, restarted N++… No success…

    Now I’m out of ideas.

  • @Kelly-Anne-Henry

    In Notepad++ v7.6 there have been some important changes regarding storage location of plugins. I elaborated in a detailed way about it in this comment (with a little correction in my subsequent comment there).

    To obtain useful help you have to provide detailed informations about your OS, Notepad++ version (32 bit or 64 bit) and your installation scenario, thus the same questions to you:

    1. Do you use a portable installation or did you use the installer to update Notepad++ to v7.6?
    2. Did you use the option “Don’t use %APPDATA%” during installation?
    3. Do you work normally with a restricted user account and thus you had to install Notepad++ using username & password of an administrative account?
    4. Please provide Notepad++ debug informations obtainable under (menu) ? -> Debug Info.

  • @Jason-JI9QD said:

    One clarification to earlier, I don’t actually have to log in as admin on this computer to install things, I only need to verify admin rights by a yes click on a popup.

    OK, that makes a big difference. So you missed what I exactly want to know with my question above.

    The paths you tried to copy the plugin to are all wrong. In %UserProfile%\AppData\Roaming… there are only the config files of Notepad++ and its plugins. The plugin DLL files have to be stored under %UserProfile%\AppData\Local\Notepad++\plugins\<plugin-name>, i.e. each plugin needs its own directory.

    Have a look at this comment where I elaborated very detailed about the whole thing.

  • I got it to work now, great. Thank you. I don’t know where I read that %APPDATA% was referring to the roaming folder, but all the other correct files were already there, so I had no reason to question it. I reinstalled the 32 bit Notepad++ so that the compare plugin would work, and put the .dll into C:\Users\USER\AppData\Local\Notepad++\plugins\ComparePlugin and it works now.

    Once again, thanks for your support. I think the directory change for the plugins is a big miss by the N++ developers, and it seems to be making it an enormous pain in the ass for everyone. I’m just glad its working again as I use that tool every day.

  • @Jason-JI9QD said:

    %APPDATA% was referring to the roaming folder

    That’s true. %AppData% is an environment variable that points to %UserProfile%\AppData\Roaming but solely %UserProfile%\AppData is just a directory.

  • simple, you should copy the dll: ComparePlugin.dll to the C: \ Program Files \ Notepad ++ \ plugins \ ComparePlugin.

  • TL;DR: After getting full permissions on the install folders I was able to successfully install the plugin. Strange/conflicting messages will show up if you don’t have write access.

    I’m in a very restrictive IT environment that requires an admin override for any software install. I also don’t have write permission to the install folder (C:\Program Files\Notepad++) or the plugins sub-directory, so I had to make a second call to get the plugin moved there.

    Using the plugin manager to install it then fails:

    1. (menu) Plugins > Plugins Admin…
    2. Check Compare (v2)
    3. Click Install.
    4. Get popup about “Notepad++ is about to exit.”
    5. Click Yes.
    6. Prompt for current user password. Enter and click Yes.
    7. Get new popup about “Notepad++ update. Can’t unzip: operation not permitted or decompression failed.”
    8. Click OK.
    9. Notepad++ opens again. Go into Plugins Admin. Compare is not installed.

    Following the Wiki instructions (as linked to from of placing the .dll into the folder seems to be in conflict with what the program is trying to do because it throws an error about unzipping. This is probably related to folder permissions, but the conflicting instructions/messages aren’t helpful. Also, the requirement that it’s in its own named folder isn’t explicitly called out in the wiki instructions. The included readme file also only says to copy the .dll to the base plugins folder.

    Looking at the advice from a few months ago about the plugins folder location is also inconsistent. Using the (menu) Plugins > Open Plugins Folder… shows my plugins as being in Program Files\Notepad++\plugins, not in the %APPDATA% location as indicated above. Most likely because I used the default option for %APPDATA% when installing (i.e. don’t use it).

    Getting full permissions on that directory allowed me to successfully install it. Step 7 above becomes “Restarts without error messages. Verified in Plugins Admin that it’s installed.”

  • For me, this turned out to be a firewall issue. We block certain outbound services that are not business necessary. Some plugins install fine, but Compare did not until I made an exception for my workstation. github comes up as “Hacking/software downloads”. So something else to check if you are baffled why Compare won’t install and have tried all of the excellent advice in this post.

Log in to reply