Collapsing Current Level and Collapse by Level don't work

  • Hi There,

    So just as the title says, when i click View Fold/Unfold All then the operation works for my indentations. But when i click view and select Collapse/Uncollapse Current Level or Collapse/Uncollapse by level then nothing happens to those levels of indentations.

    Note i am using languages that don’t need a symbol for indenting, such as Python or Nimrod.

    Also, i had the ability to Collapse/Uncollapse Level 2 once but now it stopped working.

    I am suspecting this problem to be a bug since i cant find any other reason why its not working.

    Any help would be appreciated.


  • @Max-Corman

    providing more detail like which notepad++ version you use and an example
    which illustrates the reported behavior could help identifying whether this is
    really a bug or simply a missing feature for that particular use case.


  • Hi Eko,

    Thank’s for the reply.

    I am using Notepad++ version 7.5.9 (32-bit).

    As an example lets say i have the following regular (non-code) indented text. Note i am using Notepad++ for visual basic but also for indenting regular text. In this example i used the underscores (underlines) to be able to properly indent the text in this forum. In Notepad++ there is no underlines everything is indented straight up with the tab key.

    ________exterior walls of house
    ________first floor
    ________second floor

    With the above text when i use ‘Fold’ or ‘Unfold’ they work fine. But when i try to use the ‘Collapse Level/Uncollapse Level’ operations they only work for the first level and not the second. Like i said in the original post, i had it working for level 2 at one point but that has stopped working for some reason. With text indended with more levels its the same thing where only level one works. So i cant figure out why this is happening.

    I am using the Nimrod language but it doesn’t work with Python or Matlab as well. Again, the languages i am using don’t require using a character for folding.

    Also, i tried with multiple files and its always the same thing.

    So maybe you can try the indentation using the Nimrod language with whatever version of Notepad++ you are using and let me know if it works or let me know if i am doing something wrong.

    Thanks again.

  • I should note that the Collapse Current Level and Uncollape Current Level actually do work. But they only work for one indentation. I am guessing however that this is how they are supposed to work.

    But for the Collapse and Uncollapse by Level they don’t work what so ever. I had them working for all indentations in a file for level 2 but they dont work anymore.

  • My apologies for over-posting, i would have put everything into one reply but the editing only works for a period of 180 seconds after submitting a reply.

    What i want to assert is that i never got level 2 to work with the ‘Collapse/Uncollapse Level’ operation. I thought it was level 2 but it was only level 1 that worked.

    So to summarize:
    The ‘Collapse/Uncollapse Level’ operation doesn’t work for me for the indented Levels higher than level 1 for the Nimrod, Python, and Matlab languages in Notepad++ version 7.5.9 (32-bit). The ‘Fold/Unfold All’ and the ‘Collapse/Uncollapse Current Level’ work fine.

    So either the ‘Collapse/Uncollapse Level’ is not designed to work the way i am thinking its supposed to work, or something is indeed wrong.

  • @Max-Corman

    I concur with your behavior assessment as I see the same thing with a fresh copy of 7.5.9 32-bit.

  • I just tried it on my second laptop and it doesn’t work there as well. I also tried it on a fresh copy of 7.5.1 (32-bit) and it still doesn’t work.

    So what does that mean? If it is a bug in the program then how do we report it?

  • @Max-Corman said:

    If it is a bug in the program then how do we report it?

    Under the FAQ section of this site there are instructions for doing so.

  • Ok so the folding by level applies to spaces and not tabs. That is, each space is a level. This of course is not proper since spaces are too close together.

  • For the record, from Scott Sumners posting on a thread on the GitHub forum it appears that this issue is a Scintilla issue and not a Notepad++ issue and has been rejected for fixing.

  • For anyone who is interested the issue with the folding has been fixed. You will find the instructions on how to fix the issue on your own or use the provided binaries here.

Log in to reply