Updated, now can not set as default app



  • I updated to 7.6.1 and can not set it as the default application for any extensions, lost my Snippets and TextFX disappeared.

    Running the x86 version as I heard there was issues with the 64bit one.

    I really need the Snippets and TextXF, can live with having to right click, edit with issue.

    Thanks for any and all help

    Ed



  • @Ed-Patterson
    there have been major changes regarding plugins in the 7.6.x updates, so you’ll have to reinstall your plugins using the built in plugins admin.
    go to plugins > plugins admin, select snippets and textfx characters and press install.

    alternatively you can download and install the older version 7.5.9 from here: https://notepad-plus-plus.org/download/v7.5.9.html
    if you install it over your 7.6.1 version, your plugins schould reappear as they were



  • @Ed-Patterson

    regarding the default application settings:
    did you already try to re-register your desired file extensions ?

    at the menu bar click on: settings > preferences > file association
    and register your desired file extensions by selecting them and pressing “->” to move them into the registered extensions panel.



  • – Irritating reply to ones own topic messages
    Got Snippets to work, still looking for help with Default Application and TextFX.



  • @Ed-Patterson

    – Irritating reply to ones own topic messages

    sometimes it’s necessary to refresh this page to see the answers because they sometimes don’t get updated automatically in nodebb, especially if the reply editor (composer panel) is open for a long time.
    so you didn’t really reply to your own topic ;-)

    still looking for help with Default Application and TextFX.

    i guess you got the default application to work, but regarding textfx:
    can you see the menu item plugins > plugins admin as described above to re-download textfx, or is the menu “plugins admin” missing ?



  • @Meta-Chuh
    Thanks! I now have TextFX, don’t know how I missed it before. I tried to register the .txt and .log extensions. Just checked, .txt and a bunch of others now showing as registered but double clicking on a .txt file still opens MS Notepad.

    Getting there, slow but sure. (the 20 minute delay is killer, but understandable)
    Ed



  • first you should share about installation
    v7.6.0 uninstalled with delete exiting setting
    i’m installed 7.6.1 after

    Notepad++ v7.6.1 (32-bit)
    Build time : Dec 12 2018 - 01:24:22
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (32-bit)
    Plugins : active text.dll DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll



  • @Ed-Patterson

    (the 20 minute delay is killer, but understandable)

    i just gave you 2 upvotes. your posting delay will be removed completely after a certain amount of upvotes.

    double clicking on a .txt file still opens MS Notepad.

    maybe you can do it manually:

    if you are on windows 10:
    right click on any .txt file > open with > other apps > more apps > scroll down and click on other apps on your pc > browse to C:\Program Files (x86)\Notepad++ and select notepad++.exe
    (this .txt file will now be opened in notepad++ once)
    now notepad++ is registered as an app to choose in the open with dialog.
    now you can close notepad++.

    then right click on the same text file again > choose open with > other apps > select notepad++ and check “always use this app to open .txt files”
    from now on all .txt files should open in notepad++ as the default app

    note: the windows 10 open with menu dialogs have changed a bit through time, depending on your windows updates, so the texts or some in-between-steps, like “other apps” after open with, do not exist, but present you with the apps list right away.


Log in to reply