Highlight problem, I do not want to highlight the first argument of my function.



  • If I put a space between opening brace and the first argument it is not highlighted but,
    If I do not put (write right after) it, it highlighted just like a function.
    I can not put space every function.
    That is stupid thing to do.
    Help please.

    upper picture is current problem
    lower picture is manually put a space between it
    I’d like to have just plain argument for the firs one.

    ScreenShot

    Thanks

    [posting a picture is soooo difficult in here]



  • For your problem: since you’ve got a UDL (User Defined Language), we cannot know exactly how you have things defined, so it makes it harder for us to debug your problem. If you gave us example text (see @Scott-Sumner’s Markdown on this Forum for examples of how to give sample text), along with the UDL definition (screenshots, or the UDL > Export XML results), we might be able to help you debug.

    But the UDL does have limitations, and you cannot always define a UDL in exactly the manner that will make you happy. At that point, you need a custom lexer, either by writing the lexer plugin, or using something else generic. Some months back, @Claudia-Frank made some posts on a PythonScript-based lexer, as an alternative to the builtin UDL lexer, which allows defining styles based on regular expressions. I’ve never tried to use them, but in September, at the end of this other thread, I compiled a list of links to her posts about it. I’ve never tried implementing a regex-UDL using her solution, but it may be worth trying out – I’d recommend giving it a try.

    Regarding the image: it’s not really that hard. Save the image to an external host, such as imgur (or, as you did, blogsplot). Use Markdown syntax to embed the image.

    If you don’t know Markdown syntax, you might notice in the make-a-post window, there was a little grey “COMPOSE ?”. If you click on the “?”, it directs you to the Markdown Syntax page, where you can click on the Images link, which explains the inline-image syntax. As in any online forum, you sometimes have to follow the links to the help pages to find out how to format a post; it’s standard practice.) For your screen shot, you were nearly there. You used [ScreenShot](https://1.bp.blogspot.com/-QNUC4kd4Y8I/XBiWR4JMAOI/AAAAAAAAAAM/6-G_u_9VWFAW0xG8rdhhbPZsgMftnPYAACLcBGAs/s1600/Clipboard.jpg) to link to the image; if you’d read the help files, you would have seen that to embed an image, it’s the same syntax, except prefixed with an exclamation point: ![ScreenShot](https://1.bp.blogspot.com/-QNUC4kd4Y8I/XBiWR4JMAOI/AAAAAAAAAAM/6-G_u_9VWFAW0xG8rdhhbPZsgMftnPYAACLcBGAs/s1600/Clipboard.jpg). This would render as: ScreenShot



  • All right
    Thanks for the kind reply - Peter Jones !!!

    I’ll have to find it by myself.

    Regards



  • ah
    I just have fixed it
    I missed “( )”
    so I added it
    Now works fine !!
    Screenshot


Log in to reply