Disable document switching when mouse4 is pressed



  • Hello. I see the shortcut mapper and all the keyboard keybinds, but none of them show mouse keys bound in spite of extra mouse keys switching through files when pressed. I use this key as my push-to-talk and I would like to disable this function. Is this possible?

    I should add I’ve also tried completely disabling the document switcher but mouse keys still switch through open documents.

    Thank you.



  • @trace-calvin

    isn’t this something which you normally configure via your mouse driver software?



  • No. Even if it were, it shouldn’t still be happening after disabling document switching within Notepad++.



  • If I assign something different then back and forth to the buttons via my logitech config
    software it doesn’t do switching the documents anymore.
    The document switcher you mentioned is an additional piece of logic but doesn’t prevent
    stop using the standard windows switching mechanism.
    Maybe this is mouse driver dependent - to be honest, I don’t know.



  • @trace-calvin
    As @Eko-palypse said logically it must be a mouse driver/application. If all you hit is button4 and the documents switch, then the button4 is being interpreted by something. The keyboard buffer is likely being loaded with a character combo dictated by the mouse software.

    Check the mouse software and check what your push-to-talk option (button4) really is, likely a shift-??? key combo. Now in NPP, push the same keys to confirm the document switches.

    Maybe the mouse software has a profiles option so you can change or disable button 4 when using NPP.

    Terry



  • Sorry, I should clarify. When I say this key is my push-to-talk, I simply mean it is the key that I always set across all the different programs I use. I’m not using any mouse software or macro’s. Pushing my mouse4 button in any other circumstance does nothing.



  • @trace-calvin
    I will contend that the button4 press is being interpreted by something and likely the keyboard buffer loaded with a key combo.

    If using Windows 10 have a look at this:
    https://www.microsoft.com/accessories/en-ww/support/how-to/mouse/reassign-buttons
    See if it has any helpful info.

    Terry



  • I understand what you are saying, and I know if I download some mouse management software I could tune the button to do specific things.

    But my point is that Notepad++ is directly interpreting these buttons somewhere that we (the users) don’t have access to, at least not that I can find. I just disabled every single keybind in the shortcut mapper, disabled document switching, and pressing these buttons still cycles through open documents.



  • @trace-calvin
    XButton1 - 4th mouse button. Typically performs the same function as Browser_Back.
    XButton2 - 5th mouse button. Typically performs the same function as Browser_Forward.

    So NPP cycles back through tabs on both Browser_back event and Xbutton1 event. I didn’t find any option to disable or change it. If it bothers, you can use Autohotkey script to change this button, or block completely with this script:

    #If winActive("ahk_exe notepad++.exe") 
    XButton1::return
    

Log in to reply