Bug: Click on "Encode in UTF-8 does not work"



  • On my Android device I exported a chat into a text file, then transferred this text file to my Win7 system and opened it in Notepad++ v7.6.2
    NP++ detected the content as ISO-8859-1

    Unfortunately some special chars like german Umlaute are not displayed correctly.

    So according to a previous recommendation I clicked on menu

    Encoding–>Encode in UTF-8
    resp.
    Encoding–>Encode in UTF-8 BOM

    This worked in the past resp. for other .txt files.

    Surprisingly it does not work for a certain .txt file here.

    Something flashes in NP++ for some milliseconds but nothing changed.
    In the status bar at the bottom still ISO-8859-1 is shown as format.

    Hmm, NP++ seems to reject new interpretation format.
    I guess its a bug.

    Can someone verify this?
    Thank you
    Ben



  • @Ben-S.

    at the moment you will, unfortunately, have to go to: settings > preferences > misc., and disable “autodetect character encoding” to be able to change certain files, from any encoding which is marked with a bullet in the encoding section “character sets” (weitere) to utf-8 or ansi.
    the encoding type will jump back to what it was if autodetect stays enabled.

    there are some bugs in autodetect character encoding since this commit

    i’ve filed an issue here for french, after this thread

    feel free to add any of your findings to issue 5202 and/or create a new issue for german or the “encoding bullet jumps back” issue if you like.

    note: i think it is not because of any german characters in your case, but because of smileys or other special characters, you could confirm that by using short sections of your text file, pasted to a new text file, which you then close and reopen, to (slowly/patiently) find the triggering characters and sequences



  • @Meta-Chuh:

    Thank you. Disabling let it work now :-)

    I hope that this bug will be fixed in the next release.
    Ben


Log in to reply