How to get a plugin in Notepad >= V7.6



  • Hi.

    It is not possible to install a plugin with a newer version von notpad.
    I try V7.6
    I try V7.6.1
    I try V7.6.2
    I try V7.6.3.

    I install the program with the installer, so all path settings should be correct.
    If i try to install a plugin with the plugin manager (for example compare,nppexec…),
    he ask me for the admin password (im a user without admin rights on this win 7 pc)
    but after entering the password, noting happend: no plugin will be installed.

    If i run notepad as a admin and try to install a plugin, a downgrade to V7.5.9 is the result.
    If i try to copy my old plugins to several directories (%ProgramData%, %ProgramFiles%, %PROGRAMDATA% or %LOCALAPPDATA%)
    and run NP-V7.6.3 again, only the preinstalled plugins are there!!!

    I think I’m too stupid to install the plugins???
    (or there is still a little little bug in the plugin manager???)

    Has anyone a idee to get a plugin with a newer version of NP ???



  • welcome to the notepad++ community, @Hansi-Krause

    unfortunately the old plugin manager is not compatible with newer versions of notepad++ (7.6.0 and above)

    you will have to use the new plugins adminto install plugins, as seen at the screenshots below:

    Imgur

    Imgur

    if you want to install your plugins manually and you are on version 7.6.3 (recommended, due to newest changes to the plugin locations) your plugin’s dlls have to go to %ProgramFiles%\Notepad++\plugins\PluginName\PluginName.dll

    note: the core difference is, before all plugin.dll files were inside the plugins folder directly.
    now every plugin has to have an extra subfolder, with the dll name, but without the extension “.dll”.

    greetings, and i hope this is of help to you.



  • Hi Meta-Chuh

    You explained exactly, how i try to install my plugins in notepad++ v7.6.3 with the new plugins admin. I get the same window with the plugins…

    This is exactly how the error occurs after trying to install one or more of these…



  • @Hansi-Krause : It sounds to me like you have conflicting installations, with multiple versions interfering with each other, especially from your statement, “If i run notepad as a admin and try to install a plugin, a downgrade to V7.5.9 is the result.” Because if you’ve only installed 7.6.3, it shouldn’t be able to automatically downgrade to v7.5.9.

    I am thinking you have a 64-bit 7.6.3 and a 32-bit 7.5.9 (or vice versa) coexisting with install data / registry entries conflicting – but that’s just a wild guess

    I think you might want to try to completely uninstall all copies of Notepad++; after uninstalling, delete all the %ProgramFiles%, %ProgramFiles(x86)%, %ProgramData%, and %AppData% Notepad++ subfolders (...\Notepad++ folders) and re-install from scratch. If that doesn’t work, uninstall again, and this time make sure the registry is cleaned out of Notepad++ references (run regedit.exe as admin, search for “notepad++”, and delete the associated keys) – the registry edit is more dangerous, which is why I list it as a last resort.



  • @Hansi-Krause

    in addition to all of @PeterJones 's suggestions, could you please download a portable version from >>> here <<<, extract it to your desktop and run notepad++.exe directly from this folder, and try if you can install plugins using plugins admin ?

    explanation: the portable version will be completely isolated and independent from all other existing notepad++ folders and settings on that machine.
    with the portable version you can try if plugins admin would work for you on a fresh install, just like if it would be on another machine, regardless of any other notepad++ installs you currently have.

    i have one more question: are you eventually behind a corporate proxy server that might block any downloads on your machine ?
    if you want to test this out: open a cmd command shell window and enter ping notepad-plus-plus.org. if you don’t get an answer from 37.59.28.236, you are behind a proxy server, and have to add the proxy ip and port at the notepad++ menu ? > set updater proxy


Log in to reply