files with R/r extension always open as REBOL



  • Since I updated to version 7.6.3, all my R script files are interpreted as REBOL. I have edited and removed rebol from langs.modle.xml and stylers.model.xml, disabled rebol from available languages, but it has no effect. all my R and r scripts are loaded with rebol styling. Any idea how I could change this?



  • Editing the langs.model.xml and stylers.model.xml won’t fix it. You have to edit langs.xml and stylers.xml which are in %AppData%\notepad++\. (The *.model.xml versions in your install-directory are what Notepad++ uses to create the %AppData%\Notepad++\*.xml if they don’t already exist, but aren’t otherwise read by Notepad++.)

    (edit: that assumes you have a normal install, using %AppData% for storing user settings; if you have a local config or portable version, the langs.xml and stylers.xml will be in the installed directory)

    See also this similar topic.



  • Great, many thanks, it worked!


Log in to reply