Connection with Google Cloud Computer Engine + NppFTP



  • Hello, I’m having a connection block from my IP with the Google Cloud Computer Engine. The lock happened after I tried to connect SFPT through Notepad++

    The problem is not in the server, but with some blocking that is happening between my computer route and the server. I rebooted my modem and was able to recover my access normally, as it changed my IP. But if I retry connecting through Notepad++, I will be without access again until I reboot my modem again.

    http://prntscr.com/mkcfmz
    http://prntscr.com/mkcftb

    I’ve already contacted Google Cloud Computer Engine support but since the issue is related to Notepad++, I’m looking for help here now. Thank you!



  • welcome to the notepad++ community, @Hygor-Rasec

    i have no experience with gce yet, but you could try to upgrade your nppftp to 0.28.0, if you haven’t already done so, as it has an updated libssh 0.8.6 and you are connecting using your private key.

    you can download and read more about the changes here:
    https://github.com/ashkulz/NppFTP/releases


    in the mean time, as a workaround to avoid rebooting your modem to get a new ip:
    does gce have any setting, where you can white list your current ip ?
    (something like fail2ban and/or iptables on linux)
    if yes, put your current ip into the whitelist, as your location should not pose any threat … unless your system is heavily infected 😉



  • @Meta-Chuh said:

    welcome to the notepad++ community, @Hygor-Rasec

    i have no experience with gce yet, but you could try to upgrade your nppftp to 0.28.0, if you haven’t already done so, as it has an updated libssh 0.8.6 and you are connecting using your private key.

    you can download and read more about the changes here:
    https://github.com/ashkulz/NppFTP/releases


    in the mean time, as a workaround to avoid rebooting your modem to get a new ip:
    does gce have any setting, where you can white list your current ip ?
    (something like fail2ban and/or iptables on linux)
    if yes, put your current ip into the whitelist, as your location should not pose any threat … unless your system is heavily infected 😉

    Hello,

    I made the update and the problem continues. I can connect to the server with filezilla but I cant with notepad++. It does not allow access and I’m using the same information I’m configuring in filezilla, even the private key.

    :(



  • What error does NppFTP show? If you aren’t seeing errors, go to the far-right icon of the NppFTP window and show messages window.

    If it’s the kex error, you might want to see this old post which gave more details about it, and another for the workaround that I often use, having FileZilla drive the file transfers, and just telling FileZilla to use Notepad++ as the editor.


Log in to reply