Clone/Move to other view option change text formatting in cloned/moved file



  • Hi all,

    Sometimes I need to have to files displayed side by side. And of course I use the the Move to other view option. The strange thing is, that the other panel changes text formatting. Look at this picture: link text

    Is there any solution to this - in my opinion - error?

    I use Notepad++ 7.5.9 (64-bit)

    Thanks,
    Przemek Ryk



  • @Przemysław-Ryk

    does not happen to me - did you specify some global settings via style configuration?



  • Yes. I set up my font, font size, and enabled options: enable global font and enable global font size.

    link text



  • used the same setup but don’t see that behavior.
    Which plugins do you have installed? (?menu -> Debug Info)
    Can you give it a try without using and plugins?
    Temporarily rename the plugin folder and check that those do not get loaded when restarting npp.



  • Notepad++ v7.5.9 (64-bit)
    Build time : Oct 14 2018 - 15:19:55
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 8.1 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll HTMLTag.dll ImgTag.dll MenuIcons.dll NppSnippets.dll NppToolBucket.dll PluginManager.dll



  • Screen from Plugin Manager link text. It wpould be easier to check plugins versions.

    I tried to do it without any plugins. I’ve deleted plugins folder from:
    C:\Program Files\Notepad++
    C:\Users\Rico\AppData\Roaming

    But still it shows three active plugins:
    Notepad++ v7.5.9 (64-bit)
    Build time : Oct 14 2018 - 15:19:55
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll

    And still there’s the same problem with display cloned file. Screen: link text



  • Have no idea what could cause this.
    I’ve downloaded npp 7.5.9 x64, set obsidian theme and did the font settings but still it looks the same for me.



  • wait - could it be that you accidentally zoomed the other view?
    What happens if you chose View->Zoom->Restore default zoom
    Make sure that the cursor is in the other view.



  • Yes! That’s the reason. But I don’t know, why zoom factor is changing automatically. But yes - restoring default zoom helps.

    Thank you! Thank you! Thank you! :D



  • I don’t think this is done by npp automatically but npp remembers
    the zoom level in its configuration and I assume that at one time
    you accidentally or on purpose changed it but never restored it.

    Anyway, good to see we got sort it out :-)



  • You may have bumped the mouse-wheel while holding the control button – maybe you tried to scroll immediately after doing some Ctrl+XXX operation, and the Ctrl finger wasn’t quite let go when you started scrolling. Or similarly, maybe you hit they numeric-keypad + key after a Ctrl+XXX with sticky-Ctrl-finger. My ability to do unexpected Ctrl+XXX combos never ceases to amaze me. (The one that surprised me the most was when I accidentally hit Ctrl+Win+C instead of Ctrl+C, and my screen lost most of its color; took a few minutes of googling to figure that one out.)



  • Well - whil having only one panel displayed I choose View -> Zoom - > Restore default zoom. Text is displayed at the same scale factor, but after cloning to second panel it finally isn’t zoomed up. :D

    Thank you guys once again. :D