Notepad++ as a literal scratch pad



  • I want to open a prenamed file with notepad++. The file is empty, no data. Throughout the day I have apps write text to the named file, and then I cut / paste data into trouble tickets. After each ticket is opened, I will highlight the data in notepad++ and manually delete it (named file still open, I never selected any save feature).

    I have Settings -> Preferences -> MISC : File Status Auto-Detection checked, I have Update silently checked, and Scroll to the last line after update checked.

    Under Settings -> Preferences -> Backup I have nothing selected at all, other than that default radio button still says None under Backup on save.

    I want to cut / paste into this file, delete the data over and over all day with out any pop ups, or any reloading of
    previous data what so ever.

    Notepad++ seems to make one cycle fine, but any cycle after that, I get a pop-up for:
    File has been modified, Do you want to reload it and lose the changes made in Notepad++ ?

    Thanks.



  • welcome to the notepad++ community, @Johnny-Green

    in addition to your settings, you will have to activate view > monitoring (tail -f) at the bottom of the view menu.
    (alternatively you can click on the eye symbol at the toolbar)

    this will trigger the log monitoring view.

    note: usually it will be enough to activate “tail”, and update silently is not needed, but sometimes the combination of both has worked best in the past.



  • I tried with Monitoring (tail -f) on, and it will not let me highlight and delete text… Reviewing my scenario above,
    if I scrub and delete data, so long as I hit Ctrl-S (save) after I empty the file each time, it seems to work without giving any pop-ups or warnings.



  • But this is normal and expected behavior.
    If you open a file, which gets still written by other applications and
    YOU change something in the internal npp buffer, how should
    npp know which part is the correct one?? Your changes?
    The changes from the other application?
    Did I miss something?


Log in to reply