Latest Version: Browser Export



  • I downloaded the latest version to work on my assignments for class at home. The same program on the computers at school will allow me to open the page in various browsers from within Notepad++ to test or preview it. I am unable to do this on my computer. It’s not a major issue but it is an annoyance. Anybody got any ideas?



  • The Run Menu usually contains the Launch in Firefox/Chrome/IE/Edge entries.

    They are defined in the shortcuts.xml configuration file. If you have a normally-installed Notepad++, you can edit them at %AppData%\Notepad++\shortcuts.xml; if it’s a portable, or any installation that doesn’t use AppData, it will be in the same directory as notepad++.exe itself. A caveat for editing that file: exit all instances of Notepad++ (to make sure all settings are saved); then open Notepad++ and edit the shortcuts.xml file, save and exit Notepad++. The next time you open Notepad++, the changes will have taken effect.

    Mine has Firefox and Chrome. This post shows one with Firefox, Chrome, and Internet Explorer, and explains that in the most recent versions, those entries are commented out (don’t know why, sorry). Microsoft Edge behaves differently (because Microsoft), and won’t let you just give the path to the Edge browser executable, so see this post here for how to add Launch in Edge.

    So, combining the advice from both posts:

        <UserDefinedCommands>
            <Command name="Launch in Firefox" Ctrl="yes" Alt="yes" Shift="yes" Key="88">firefox "$(FULL_CURRENT_PATH)"</Command>
            <Command name="Launch in IE" Ctrl="yes" Alt="yes" Shift="yes" Key="73">iexplore "$(FULL_CURRENT_PATH)"</Command>
            <Command name="Launch in Chrome" Ctrl="yes" Alt="yes" Shift="yes" Key="82">chrome "$(FULL_CURRENT_PATH)"</Command>...
            <Command name="Launch in Edge" Ctrl="yes" Alt="yes" Shift="yes" Key="69"> shell:Appsfolder\Microsoft.MicrosoftEdge_8wekyb3d8bbwe!MicrosoftEdge $(FULL_CURRENT_PATH)</Command>
    

    (There may be other entries in the <UserDefinedCommands> section before or after these; I just included the start-tag to tell you where in the file to add the launch-in-browser commands)

    If you know the full path to another browser that you want to use, you can add another row similar to those, but with

            <Command name="Launch in SuperSecretBrowser" Ctrl="yes" Alt="yes" Shift="yes" Key="0">&quot;c:\path\to\browser.exe&quot; &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    

    If you want to change the shortcuts, go to Run > Modify Shortcut / Delete Command



  • @PeterJones said:

    This post … explains that in the most recent versions, those entries are commented out (don’t know why, sorry).

    It’s because of an “issue” found due to the EU-FOSSA bug bounty program currently running for Notepad++, see the comment of this commit.



  • @PeterJones I removed the comment tags and still do not see an option to launch in any of the browsers. Any other ideas?



  • Did you edit the right shortcuts.xml? Did you remember to do the exit, notepad++, edit, save, exit, notepad++ sequence that I gave?

    Please give us your ? > Debug Info > Copy debug info into clipboard, and tell us the full path name to the shortcuts.xml that you edited (if it’s still open, RClick on the tab name, select Full File Path to Clipboard).


Log in to reply