Drag and Drop not working in portable 7.6.3

  • Hello

    I have downloaded the portable version of NPP++:

     Notepad++ 7z package 64-bit x64: Don't want to use installer? 7z format.

    Everything works fine, except that drag and drop does not work in NPP++. Asking friend Google shows that this problem appears some years ago.

    Has someone an idea?

  • @Pere-Drinovac

    When you attempt the drag and you move over the Notepad++ window with your file, what does the mouse cursor look like? Is it a black circle with a line thru it (or some such?).

    Also, can you paste your debug info here? Do ? menu, then Debug info, then click on Copy debug info into clipboard, and finally paste that into a reply here.

  • The cursor changes to a “cursor + rectangle and ‘+’ sign” (right bottom corner of the cursor).

    Here are the required information:

    Notepad++ v7.6.3 (64-bit)
    Build time : Jan 27 2019 - 17:16:47
    Path : C:\PortableApps\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 10 (64-bit)
    Plugins : BetterMultiSelection.dll ComparePlugin.dll CustomLineNumbers.dll DSpellCheck.dll ElasticTabstops.dll mimeTools.dll NppConverter.dll SelectQuotedText.dll SQLinFormNpp64.dll _CustomizeToolbar.dll

  • I have figured out, that drag and drop from Windows Explorer works.

    But drag and drop from Total Commander does not work. With 7.5.x it also worked with Total Commander.

  • @Pere-Drinovac said:

    I have figured out, that drag and drop from Windows Explorer works.

    But drag and drop from Total Commander does not work. With 7.5.x it also worked with Total Commander.

  • @andrecool-68

    I take it that you are saying that drag and drop works fine for you from Total Commander to N++ 7.6.3?

  • @Alan-Kilborn
    Yes this is the latest version of Notepad++ and these builds are portable

  • @Pere-Drinovac
    Or do you need to make Notepad++ the default editor for Total Commander?

  • @Pere-Drinovac

    under normal circumstances drag and drop from total commander will work correctly, as seen at the screen video of @andrecool-68

    i can however reproduce what you see, if either total commander is running elevated as administrator, while notepad++ is running as a default user, as well as if it is the other way round.

    if you need one of them to run elevated as administrator, to e.g. be able to access protected files, you will have to disable the windows user access control (uac) as uac is the cause that blocks passing data from user level applications to elevated applications and vice versa.

    to disable uac in windows 10:

    • hit the windows icon and type uac in the search field as seen at the screenshot below:


    • then open up Change User Account Control settings and slide the slider down to the bottom as seen at the screenshot:


    • then hit ok and reboot your machine.
      after reboot, you will now be able to drag and drop files from total commander to notepad++ under (usually) all circumstances.

    note: keep in mind, that uac is activated for security reasons, to make sure no application can write or change some vital file locations, without your consent, but you will be on the safe side as long as you take care of what you are doing.

    i hope this is of help to you.

  • Both, Total Commander and N++, are portable and running with user privileges. Deactivating UAC doesn’t change anything.

    I have figured out, that I used TC as 32Bit version and N++ as 64Bit version. Using N++ as 32Bit version solves the problem.

  • I have everything works fine on all portable versions, no matter x32or x64 (in any combination!)

  • @Pere-Drinovac
    I have now changed the UAC settings. And these changes to UAC settings do not affect this operation at all! Everything works fine.

  • @Pere-Drinovac

    thanks for sharing your solution.

    i’m glad you got drag and drop working by using the 32 bit versions for both, without needing to disable uac.


    yes, it might be that our systems differ somehow from the original poster’s system.

    i also get the same results as you did: i can drag from 32 bit total commander to 64 bit notepad++ without any problems.
    and if uac is enabled on my test-machine, i can drag and drop from an elevated total commander to a user level notepad++,
    but i can not drag and drop from a user level total commander to an elevated notepad++.

    i guess the most important thing is, that the o.p. has managed to get drag and drop working for him, regardless how ;-)

  • I would like to thank all of you for the help.

Log in to reply