Problem mit Notepad++ / Problem with Notepad ++



  • Hallo, Ich habe zwei Probleme mit Notepad++ wenn ich eine c++ Datei oder ähnliches bearbeite, dann macht er manchmal nach dem Speichern einfach in die Zeilen wo ich gearbeitet habe ein “?” rein was beim compilen dann natürlich immer zum Fehler führt und mein zweites Problem ist dass die Suche nicht richtig klappt obwohl ich 1zu1 eingebe was in der Datei zu finden ist (Wenn ich den Text doppelklicke und Strg + F drücke dann findet er es)

    Hello, I have two issues with Notepad ++ when editing a c ++ file or something like that, then sometimes after saving it just makes it into the lines where I’ve worked a “?” purely what compiles then of course always leads to the error and my second problem is that the search does not work properly although I 1zu1 enter what is in the file to find (If I double-click the text and press Ctrl + F then he finds it)



  • willkommen in der notepad++ community, @Dennis-Schlüter

    kontrollier mal, ob die datei die du z.b. als utf-8 gespeichert hast, nach dem schliessen und erneuten öffnen in notepad++ noch immer die gleiche kodierung hat, oder fälschlicherweise als vietnamesisch windows-1258 oder andere erkannt wird.
    (die aktuelle kodierung, zb, utf-8, ansi, etc, siehst du immer in der rechten unteren ecke, im vorletzten feld der notepad++ statuszeile)

    seit der version 7.6 funktioniert nämlich die automatische erkennung der zeichensätze nicht mehr, und umlaute oder sonderzeichen bekommen beim neu einladen wirre zeichen, fragezeichen, oder doppelzeichen zugeordnet.

    derzeit ist der einzige workaround dafür, in einstellungen > optionen > diverses den haken bei kodierung automatisch erkennen zu entfernen,
    und in einstellungen > optionen > neue dateien auf utf-8 zu setzen (oder ansi, wenn du überwiegend dieses format verwendest)

    vielleicht behebt dies auch dein 2. problem, die suche nach einer spezifischen character sequenz, wenn sie eingetippt statt markiert/gepasted wird.


    welcome to the notepad++ community, @Dennis-Schlüter

    please check if your files are still keeping the same, correct character encoding you need, like utf-8, once you exit notepad and reopen this file,
    or if your file gets another encoding like vietnamese windows-1258 or anything else after a reload.
    (you can see the character encoding at the penultimate field at the bottom right of the notepad++ status bar)

    since version 7.6 the character auto detection is broken, and files with special characters will often be detected incorrectly.

    currently the only workaround is to disable settings > preferences > misc. > autodetect character encoding and set your preferred encoding, like utf-8, at settings > preferences > new document.

    maybe this also solves your second problem of finding a specific character sequence, if typed instead of marked/pasted.



  • Ich arbeite an Python und c++ Dateien die da wäre ansi die Beste lösung so weit ich weiß oder?

    Danke für die Antwort!

    Das mit den Sonderzeichen und Umlauten hab ich auch schon länger, kann auch gerne mal ein Projekt zerstören was sehr lange gedauert hat, sehr ärgerlich bearbeite dann meistens kleinere Dinge mit dem Windows Editor :D



  • @Dennis-Schlüter said:

    Ich arbeite an Python und c++ Dateien die da wäre ansi die Beste lösung so weit ich weiß oder?
    Danke für die Antwort!
    Das mit den Sonderzeichen und Umlauten hab ich auch schon länger, kann auch gerne mal ein Projekt zerstören was sehr lange gedauert hat, sehr ärgerlich bearbeite dann meistens kleinere Dinge mit dem Windows Editor :D

    With the right encoding line, python works just fine with utf8. However, @Meta-Chuh said “like” utf-8; if you’d rather set your preferred default encoding to “ANSI”, that’s fine too. The main issue is that autodetect cannot be relied upon in the recent versions.

    Mit der richtigen Kodierungszeile funktioniert Python mit utf8 gut. @ Meta-Chuh sagte jedoch “wie” utf-8; Wenn Sie Ihre bevorzugte Standardcodierung lieber auf “ANSI” setzen möchten, ist das auch in Ordnung. Das Hauptproblem ist, dass in den letzten Versionen nicht automatisch auf die automatische Erkennung zurückgegriffen werden kann.



  • @PeterJones

    it seems as if we all get more and more multilingual lately …

    … if it continues like that, @Alan-Kilborn is going to answer every request in swedish only, and @guy038 will do all explanations in a specific japanese dialect, only spoken in a single village, north of gokayama 😂😂😂

    @Dennis-Schlüter
    yes, @PeterJones is absolutely correct.
    as long as you stick to one single encoding (like ansi) and no other software requires anything else (like utf-8), you will be on the safe side.
    and it is better to rely on yourself, choosing the file format encoding, than any auto-detection.

    note: once you manually changed to ansi, please re-check all vital documents for incorrect characters instead of german umlauts, as wrong characters are likely to exist, once the document has been switched back and forth from one encoding to another.


    @PeterJones

    最近私たち全員がますます多言語を話すようになります…

    …それでもこのように続けば、アランはすべての要求にスウェーデン語で答えることになります、そして男は特定の日本語の方言ですべての説明をするでしょう、gokayamaの北の単一の村で話されるだけです😂😂😂

    @Dennis-Schlüter
    はい、@PeterJones は正しいです。
    (ansiのように)1つのエンコーディングに固執し、他のソフトウェアが(utf-8のように)他に必要としない限り、あなたは安全な側にいるでしょう。
    自動検出よりも、ファイル形式のエンコーディングを選択して自分に頼ることをお勧めします。

    注:手動でansiに変更した場合は、文書をあるエンコードから別のエンコードに切り替えた後に、誤った文字が存在する可能性があるため、重要な文書すべてにドイツ語のウムラウトではなく誤った文字がないか再確認してください。

    😉


Log in to reply