( { } ) show long area before/ after



  • I had recently experimented with fonts.

    Now I finding that when I use Arial Unicode MS as my default font, when I type ( { } ) there is a long used area before/ after the characters.

    screenshot

    (that long vertical line at ) above is cursor.

    It is not space character. There is just nothing. I can’t delete anything there.

    the entire area of ( { } ) in the screenshot is taken by that sole character.

    As (){} bolden and change color on selection, to show matching braces, it is confusing as to what is happening and what is see now is different from my years of use of npp so I feel uncomfortable and my productivity is reduced.

    Also, often (){} appear behind another character for some reason

    When I copy paste such text to other applications, it reverts to normal single character width there without me doing anything for that.

    Why has it happened and what is the solution to it. I am sure that it has happened only due to experimenting with fonts, I had not done any changes in npp in the last week.

    Thanks.



  • In text editors it is better to use monospaced fonts, they are the same size



  • @V-S-Rawat

    I’m going to guess that you never use column-selecting! :)



  • :-) Yeah, I never need to use column mode.



  • The point is: Everything was working well for years with Arial Unicode MS and then last week I tried a Unicode Nirmala UI font, but didn’t like this so now switched back to Arial Unicode MS, and now this problem presents.



  • @andrecool-68 Hindi-Devanagari text just can’t use monospaced fonts. All characters are different width with above-below-right-left ligatures.



  • Hello, @v-s-rawat,

    Could your verify that, when your text has a strange behaviour, if it contains some invisible Unicode format characters ?

    • Open the Mark dialog ( Search > Mark... )

    • SEARCH [\x{200B}-\x{200F}\x{202B}-\x{202F}\x{206A}-\x{206C}]

    • Check the Purge for each search option

    • Select the Regular expression search mode

    • Click on the Mark All button

    If your file contains such characters, a red thin cursor should appear, at any location where an invisible format character occurs, generally between two standard characters !

    In that case, just wipe them out, doing a S/R, with an empty replacement zone !

    Best regards,

    guy038

    P.S. :

    I, personally, would be very, very sad to miss the column mode selection, especially, in conjunction with the excellent Dail’s plugin BetterMultiSelection ;-))


Log in to reply