Problem with UTF files with polish characters



  • Notepad++ 7.6.2

    Scenario like this:

    Create new file:
    write: DĄBB
    save as UTF, open, everything OK

    Create new file:
    write: DĄBBB
    save as UTF,
    open
    file open as “Windows-1252” and presents “DÄ„BBB” and I can’t change codding into UTF

    switch: “Coding in UTF without BOM” do nothing

    But if I remove last “B” and save “DÄ„BB”
    and open again file:
    file open in UTF and presents : “DĄBB”

    can someone help me ???



  • welcome to the notepad++ community, @Adro-R

    unfortunately autodetect character encoding is broken since notepad++ version 7.6. and above.

    currently it is necessary to:

    • go to settings > preferences > misc and disable auto detect character encoding as seen at the screenshot below.

    settings - auto detect character encoding

    • then go to settings > preferences > new document and set your preferred default encoding to e.g utf-8, as seen at the screenshot below.

    Imgur

    after that repeat your testing, it will work now.

    note: a solving regression rollback fix for that issue has finally been commited and pushed to the pull requests, but it has currently been suspended by @donho for yet unknown reasons.



  • thanks,
    this solves my problem and the file now loads correctly


Log in to reply