Global Styles empty



  • Hello, I have old version of npp on my client’s RDP (v6.7.9.2). For some time I observe that Global Styles are not working properly. In Style Configurator, field Style is empty as presented on screenshot and I’m not able to change global font. I checked stylers.xml file and it is the same as on my PC. Also importing of new stylers file have no effect. I didn’t add any plugins during the period when styles were broken.
    This is very annoying me as I need fixed width character font to work with files.



  • welcome to the notepad++ community, @Marcin-Frankowski

    do you know, if the global styles menu entries can be seen on the local monitor or via team viewer ?

    reason: i had similar problems with other applications, when connecting via rdp to a client. on the local monitor everything was there, but not when connecting via rdp.

    if this is the case for you too, i was sometimes able to work around this temporarily, by changing rdp resolutions, colour depth, session resolution, windowed view, using mstsc.exe or any other rdp client, instead of the ms rdp app or vice versa.
    all on a trial and error base.



  • @Marcin-Frankowski

    ps: if you want to re-check, if it is notepad++ or rdp in your case, or in case you only have rdp available right now:

    download the official portable notepad++ from here:
    https://notepad-plus-plus.org/repository/7.x/7.6.5/npp.7.6.5.bin.zip
    extract it to your client’s desktop.
    close your client’s notepad++ 6.7.9.2.
    execute the portable notepad++.exe inside the npp.7.6.5.bin folder and see if the global styles menu is empty or not.

    (the portable version does not require any installation and runs completely independent and isolated from your installed version. all custom settings, as well as any stuff you might want to try at the portable version, will not modify your installed version)



  • Unfortunately the policy is very restrictive and I can access only with Citrix Receiver. Additionally client’s support is not the fastest so I wanted to check first here as maybe this is some known bug.



  • @Marcin-Frankowski

    i don’t recall any known bug in 6.7.9.2. which could have caused this.

    in the mean time, while you have to wait for the mandatory posting timeout for new users, until you can post again:

    if the policy is very restrictive and you are not allowed to use anything else than version 6.7.9.2, you can give it a try with the official portable version of notepad++ 6.7.9.2 from here:
    https://notepad-plus-plus.org/repository/6.x/6.7.9.2/npp.6.7.9.2.bin.zip

    either by using it at the client’s machine desktop,
    or by first making a backup copy of the client’s C:\Program Files (x86)\Notepad++ folder, and then copying the content of npp.6.7.9.2.bin.zip to C:\Program Files (x86)\Notepad++, replacing all old files, to check if it get’s better with all original old notepad++ files.

    note: you can skip copying the file doLocalConf.xml. this empty file will trigger the portable behaviour. if it is present, notepad++ will try to save settings to the program folder instead of %AppData\Notepad++



  • @Meta-Chuh
    No issue when using portable in both versions. Using portable from desktop could be workaround for me. It seems that I’ll need to ask client’s support for re installation because I even can’t reinstall on my own.



  • @Marcin-Frankowski

    Using portable from desktop could be workaround for me.

    splendid, at least this get’s you going for now.
    you can move the portable folder anywhere you have r/w rights, if you prefer to hide it from the desktop.

    greetings, and we’ll be here if you need anything.


Log in to reply