Notepad++ seems to have stolen & replaced Notepad



  • Hi there, I’ve just installed Notepad++ last version and it seems to have stolen ou deleted the Microsoft basic version of Notepad.
    I know it is located here : C:\Windows\System32\notepad.exe
    But it doesn’t open anymore since the installation of Notepad++ : Notepad++ opens instead !

    Please don’t ask me why I need both of these.
    I do.

    Any help ?



  • @Antoine-Boniface said:

    Hi there, I’ve just installed Notepad++ last version and it seems to have stolen ou deleted the Microsoft basic version of Notepad.
    I know it is located here : C:\Windows\System32\notepad.exe
    But it doesn’t open anymore since the installation of Notepad++ : Notepad++ opens instead !

    Assuming you installed Notepad++ from the normal installer, downloaded from https://notepad-plus-plus.org/download/, it did not “steal” or “delete” WIndows’ notepad.exe. This can be easily proven by hitting the WindowsKey plus the letter R (Win+R), and typing notepad.exe and clicking OK (or hitting Enter). If running that executable actually launches Notepad++, then you have either gotten your notepad++ from a non-official source, or you have one of the plugins or other setups which intentionally try to hijack notepad.exe with Notepad++. I agree, that’s a bad idea, but some people want it, so others provide solutions.

    What likely happened is that when you installed, the installer told windows you wanted to associate .txt files with Notepad++ instead of with notepad.exe (which people often want to do), so when you double-click on a .txt file, Windows launches it with Notepad++ instead of notepad.exe. This is what most people want when they install Notepad++. If you want .txt to default to the Microsoft notepad.exe, then you just right click on a .txt file, and tell Windows to “open with” and “choose another app”; when it does so, click on “Notepad” and then select “always use this app for .txt files”.

    Or, if you want .txt to default to Notepad++, but want to open a particular .txt file with notepad.exe, do the “open with”, and select notepad, without telling Windows to “always use this app”

    (Note: I have used Win10 terminology and sequences here; Win7 is similar, but sometimes the phrasing is slightly different.)

    (There are many other ways to fix this, including using the registry… But editing the registry directly is not a good idea for everyone.)

    edit: If you go to the Notepad++ menu ? > Debug Info > Copy debug info into clipboard, and paste that in your reply, you will give us more information, which may enable us to customize our response to your actual situation, rather than just guessing.

    edit 2: And sorry, I forgot to welcome you to the Notepad++ Community Forums. I hope we’re able to help you through your issue.


Log in to reply