Export file colummsepator changed from tab tot multiple spaces



  • Hello,

    With a program I made a *.txt file. The columns were separated by one tab. I have a new server, now is a *.txt file is created where the columns are separated by multiple spaces.

    I used the *. txt file as import file for another program. This isn’t working anymore because the tabs are missing.

    My question is:

    1. is there any reason why a .txt file on the server now all of a sudden is separated by spaces. The program where I export file (. txt file) is not changed
    2. is there a method to remove all unnecessary spaces into one, and then to turn it into one tab

    Ik wanted I can sent examples of the file before and after

    Thanks in advance

    Peter Leenen
    The Netherlands



  • @Peter-Leenen

    do you mean that you edited the file on the new server with npp which then changed the
    tab to spaces? If so, take a look at Settings->Preferences->Language,
    there is a section Tab Settings. Maybe the replace by space has been checked.
    Under Edit->Blank Operations, there is a Tab to space method.



  • No the program I have (Unit4 Bussiness Suite) makes a export file to a *.txt file. NPP is not running on my server (only NotePad). Before the exportfile was sperated by single tabs now multiple spaces. I do not understand why it changed. Before my server was running on Windows Server 2008 R2 now it is running on OLP Windows Server Standard 2019.

    Peter



  • @Peter-Leenen,

    From the sequence you have described, I am not sure why you think that asking Notepad++ experts will be able help. You seem to be indicating that this application that you’ve called “Unit4 Bussiness Suite” on a server that is used to generate its .txt with tabs, and now generates its .txt with spaces. If that’s the case, I would go ask in a “Unit4 Bussiness Suite” forum or helpdesk, or go change the configuration of that app.

    If you are really trying to say that “Unit4 Bussiness Suite” generates a .txt with tabs on its server, but when you open it with Notepad++ on your local machine, the .txt has spaces, then you need to clarify that, and you need to explain the exact process:

    1. how do you get the file from the “Unit4 Business Suite”'s server to your local machine?

      • Are you opening on a mounted drive (\some\machine\path) or (z:\blah.txt)?
      • Are you using a webserver to download the file?
      • Are you using FileZilla or some other FTP/SFTP/SCP/RCP client to grab the file?
      • Are you using a plugin in Notepad++ to open the file from the server (like NppFTP)?
    2. How do you open it in Notepad++?

      • Are you using NppFTP to open it directly?
      • Do you use File > Open,
      • Do you double-click on the file in a Windows Explorer?
    3. Are there any scripts or plugins that get run (manually or automatically) in between transferring it and opening it in Notepad++? Or do you have a PythonScript that you run when it opens? Or do you have a specialty plugin to help with U4BS .txt files?

    Also, I’m wondering if it’s just a display issue; if Notepad++'s Settings > Preferences > Language > Tab Settings: [Default] says “tab size: 1” or some other small value, maybe you’re just not noticing that it’s a tab. Try setting that number big, or try View > Show Symbol > Show Whitespace and Tab.



  • @PeterJones

    Dear Peter,

    Thank you for your quick answer. The problem is what you say in the first sentence. Of course I called Unit4 and asked them if they change anything. They did not. The new server is installed so I was looking if the problem is on the new server software. Maybe something changed in the notepath files. On the server I did try to change language settings, but this did not solve the problem.

    Tomorrow I wil look the procedure of the export file on the server.

    Peter


Log in to reply