DBGP Plugin v0.0.13.27 can't work on Notepad++ v4.6.6 and v4.6.4



  • Hello, I’am a Autohotkey Programmer in Japan.
    I’ve installed DBGP Plugin v0.0.13.27 on Notepad++.

    First Try)
    I’ve downloaded DBGP Plugin v0.0.13.27, And I installed Notepad++ v4.6.6.
    I’ve copied DBGpPlugin.dll into Notepad++ Plugins folder.
    And selected Notepad++ Plugin Menu.
    But Notepad++ does not show “DBGp” in Plugin Menu.

    Second Try)
    I installed Notepad++ v4.6.4. and Try to use DBGpPlugin.dll.
    But Notepad++ does not show “DBGp” in Plugin Menu.
    Is this intentional?

    Third Try)
    I installed Notepad++ v4.5.8. and Try to use DBGpPlugin.dll.
    And It works correct!
    I can set breakpoint and I can see all the variables of Autohotkey script.

    Best Regards.



  • Test Environment(OS): Windows10 64bit
    Notepad++ v4.6.6 (32bit) + DBGP Plugin v0.0.13.27 … DBGp didn’t work.
    Notepad++ v4.6.4 (32bit) + DBGP Plugin v0.0.13.27 … DBGp didn’t work.
    Notepad++ v4.5.8 (32bit) + DBGP Plugin v0.0.13.27 … DBGp works correctly.

    DBGP Plugin v0.0.13.27 download URL:
    https://sourceforge.net/projects/npp-plugins/files/DBGP Plugin/DBGP Plugin v0.13 beta/

    Notepad++ download URL:
    https://notepad-plus-plus.org/



  • welcome to the notepad++ community, @k-ayaki

    i believe that you were not using version 4.6.6 (four-six-six)
    but you were on version 7.6.6 (seven-six-six)

    if you prefer to use the newer notepad++ version 7.6.6 instead of the older 7.5.8 that works for you, then do the following:

    how to install dbgpPlugin on notepad++ 7.6.6:

    • download DBGpPlugin_0_13b_dll.zip and extract it.
    • go to the menu plugins > open plugins folder...
    • create a folder called dbgpPlugin
    • copy dbgpPlugin.dll from your extracted DBGpPlugin_0_13b_dll.zip into the dbgpPlugin folder.
    • restart notepad++.

    dbgpPlugin will now show up in your plugins menu, as seen at the screenshot below:

    Imgur



  • Dear Meta Chuh.

    i believe that you were not using version 4.6.6 (four-six-six)

    You are correct! The version that I tried were 7.6.6.
    And I successed to install dbgPlugin on v7.6.6.

    I wrote this tips on Qiita.com (Japanese Technical forum)
    https://qiita.com/kenichiro_ayaki/items/29a60514ff63f666e26a



  • @k-ayaki

    very good, thank you for reporting back.

    and many thanks for sharing your very detailed guide at qiita for all users.
    you have very nice details, for example including the correct absolute program files paths, for both windows 32 bit and 64 bit. 👍



  • From a first look seems it could be also added to the PluginAdmin list. I will do that.


Log in to reply