Autosave not working in v 7.6.6



  • Initially autosave did not show up under the new Plugins Admin screen. I created an autosave folder (under plugins) and added the plugin there. It then shown up on the menu-bar under plugins but it did not show up on the Admin screen. Also , setting the autosave option has no effect. Is this a bug?

    Any suggestions appreciated.



  • @Mike-Behar

    to get autosave running on notepad++ 7.6.6:

    • if you have an AutoSave version below 1.6.0, please download the newest version AutoSave_dll_1v60.zip from >>> here <<< and extract it.

    • click on plugins > open plugins folder... to open the plugins folder in windows explorer.

    • make sure the plugin folder you created is exactly called AutoSave.

    • copy your needed 32 or 64 bit version of AutoSave.dll from the extracted zip to your plugins\AutoSave folder, eventually replacing the old AutoSave.dll.

    • restart notepad++

    • if you now go to plugins > autosave > options you can activate e.g. at timed intervals every, set your minutes e.g to 1, edit a loaded test file and you will see that it will automatically save after a minute.
      (the tab disk icon will change from red to blue, and the file timestamp will be the current time)

    note: the plugin will show up at the plugins adminscreen at the category installed.

    hope this helps and best regards.



  • @Meta Chuch Unfortunately still not working. Folder is named AutoSave, my version was 1.6.0.0 created February ‎8, ‎2017, ‏‎10:58:16 AM the same as the version in your 64 bit folder which I extracted and used.
    It does now show up in at the plugins admin screen (category installed.) Setting the timer to 1 minute still does not save the modified file. I tried running N++ as Administrator – still no luck.

    Any suggestions about how to debug this would be appreciated. I am kinda addicted to autosave and will revert to an older version of N++ if I must.

    Thanks again,
    Best



  • it works fine for me but I’m running the 32-bit version of npp,
    I wouldn’t recoommend the 64-bit because most plugins don’t work,
    can you try the 32-bit version of the program and plugins?



  • @Mike-Behar

    thank you for your very detailed report.
    this is very intriguing, as i can not reproduce it yet.

    i have just tested autosave 1.6.0. on notepad++ 7.6.6 64 bit and it seems to work, as well as showing up as installed at the plugins admin panel, as seen at the screenshot below.

    autosave x64 correctly saves a file if it is unsaved.
    (note: unnamed/new files are ignored at my test settings)

    i have set it to check for unsaved files every 1 minute.
    if i open a saved file and edit it without saving, it gets correctly auto-saved after 1 minute.

    Imgur

    have you been on notepad++ 64 bit before and just updated it, or is your current notepad++ a completely fresh install ?

    my debug info:

    Notepad++ v7.6.6   (64-bit)
    Build time : Apr  3 2019 - 23:52:32
    Path : C:\Users\User\Desktop\npp.7.6.6.bin.x64\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7 (64-bit)
    Plugins : AutoSave.dll mimeTools.dll NppConverter.dll 
    


  • @patrickdrd. Good suggestion. I have had no problems with running the 64 bit version given the plugins I use. But I agree it would be better to go to a 32 bit version rather than an older 64 bit version. Hopefully Meta Chuh can solve the mystery

    @ Meta Chuh. Hope the following helps.

    Image 1 shows that a temp file is being created but that does not change the red unsaved image. The temp file actually has the changes. I also noticed a “ripple” happens at the one minute mark. That ripple also happens when NP++ loses focus, but again the temp file is not converted nor does the unsaved image change.

    image #1

    Some additional information:
    Image #2

    Image #3

    Image #4

    Again, I hope this helps.

    Best,

    Mike



  • @Meta-Chuh Sorry, I forgot to give the debug info

    Notepad++ v7.6.6 (64-bit)
    Build time : Apr 3 2019 - 23:52:32
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : AutoSave.dll HTMLTag.dll mimeTools.dll NppConverter.dll NPPJSONViewer.dll PluginManager.dll



  • @Mike-Behar

    many thanks for your detailed information.

    please test the following, to verify, if a clean notepad++ would work with autosave on your system.

    • download the notepad++ 7.6.6. 64 bit portable version from >>> here <<<.
      (the portable version does not require any installation and runs completely independent and isolated from your installed version. all custom settings, as well as any stuff you might want to try at the portable version, will not modify your installed version)

    • extract npp.7.6.6.bin.x64.zip to e.g. your desktop.

    • important note: make sure to close all instances of notepad++ that might be running, before starting the portable version at the next step, to be sure you are using the portable version for this test.

    • open the extracted npp.7.6.6.bin.x64 folder and start this portable version by double-clicking on notepad++.exe inside this folder.
      (note: notepad++.exe will just be seen as notepad++, if you have enabled to hide all known file extensions at your explorer settings, which i think might not be the case as you have that strange .txt~ extension at NP++DebugInfo.txt)

    • install the autosave plugin on this portable version, like above, starting with opening plugins > open plugins folder... and try if it works on this clean, 64 bit notepad++ 7.6.6 portable version.

    if it works, we can either figure out and solve the differences between installed and portable notepad++ that cause this experience, or, as we then would know, that a complete fresh install would work on your system as expected, we could guide you through that, if you wish.

    thank you for your help and best regards.



  • @Meta-Chuh ,

    More thanks to you for helping (and creating/supporting AutoSave)

    **Good News (and bad news) **

    **Good news **is AutoSave will work with these
    correct settiings
    https://i.ibb.co/M9y2Hfb/NP-Correct-Settings-2019-04-17-211651.jpg
    Note: Previously I had the Save in same directory option selected. I think this is what was creating the temp file with the ~ ending. To make it work the overwrite option needs to be selected.

    ** Bad News **–Portable version of NP++ gives this error
    NP++ Portable error
    https://i.ibb.co/RQbyhM7/NP-Port-missing-gpup-019-04-17-212937.jpg

    In addition the Portable version does not create an Autosave Folder…
    This is true for the link you provided as well as for the link on Portable Apps
    https://i.ibb.co/ypNyxrZ/N-P0rtable-2019-04-17-204519.jpg

    Bottom line for me is – AutoSave works and I am again a happy camper.

    Thanks so much for your help.

    Mike

    PS
    How did you get the images to display in your answer? What is the markdown magic?



  • @Mike-Behar

    **Good news **is AutoSave will work with these
    correct settiings

    congratulations 👍


    ** Bad News **–Portable version of NP++ gives this error
    NP++ Portable error

    plugin manager is not compatible with newer versions of notepad++.
    please don’t install it.


    In addition the Portable version does not create an Autosave Folder…
    This is true for the link you provided as well as for the link on Portable Apps

    that’s why i said: install the autosave plugin on this portable version, like above, starting with opening plugins > open plugins folder... and try if it works on this clean, 64 bit notepad++ 7.6.6 portable version. above.
    you had to create the Autosave folder before, so it is still the same for the portable version. (the portable version is completely isolated and does not assimilate your installed version’s settings or folder structure)


    Bottom line for me is – AutoSave works and I am again a happy camper.
    Thanks so much for your help.

    that’s the only important thing.
    you are very welcome.


    PS
    How did you get the images to display in your answer? What is the markdown magic?

    the magic is to put your image url in between ![]( and ).
    example:
    ![](https://i.ibb.co/M9y2Hfb/NP-Correct-Settings-2019-04-17-211651.jpg)

    will produce this:

    best regards



  • @Mike-Behar said:

    This is true … for the link on Portable Apps

    Please don’t. Just don’t. Portable Apps rebundles things, and has a history of messing up their bundle so Notepad++ doesn’t work properly.

    If you want a portable non-installed Notepad++, just use the “zip” or “7z” link from the official website, rather than going to a rebundler/distributor like Portable Apps.



  • @PeterJones said:

    Please don’t. Just don’t.

    I can’t upvote this enough.

    Always get N++ from here whether you want installable or portable: https://notepad-plus-plus.org/download



  • Last month, I opened a ticket to get the download page to add “portable”, and I just posted a comment to “bump” the issue. @Meta-Chuh has kindly upvoted it. Hopefully, we can get the official download pages to emphasize that there is a portable version officially available.



  • @Meta-Chuh
    Just to be clear… I did use the original link you provided to download NP++. It threw this error
    (And thanks for the markdown tip)

    I added the missing “gpup.exe” and created the folder as before. It was then I discovered the “correct” settings to make AutoSave work. After that – for fun – I tried the portable apps version – and hit the same error message

    So here is what is not clear to me.

    1. Am I the only one seeing that error message or is something broken on BOTH sites where we can get a portable version of NP++ ?

    2. Why does checking “save autorecover in the same directory” create a file extension that end with ~ Should it not create a file with the same name and an extension of bak or something similar?

    Thanks

    @PeterJones and @Alan Kilborn
    I appreciate the advice – thanks. Hope the main site will clear show a portable version is available…

    Best to All,

    Mike


Log in to reply