Special Character Issues



  • I have an issue with special characters that i can’t find a way to fix

    Examples:

    Normal Text - https://i.imgur.com/upKBAsa.png

    Pasted Text - https://i.imgur.com/pjiujWJ.png

    I’ve tried changing the encoding and even messed with the style configurator to no avail.

    Apologies in advance for anything i do or may have done wrong, I’m new to this site and this problem is the only reason i’ve come here.



  • welcome to the notepad++ community, @English-Crusader

    the most widely used file format for those characters is utf-8.
    if you are on notepad++ versions 7.6 to 7.6.4, there was a bug concerning the automatic character encoding function, so if you reload such an utf-8 file, it will be interpreted as something else, messing up the characters.

    if this is the case, it is recommended, that you update to notepad++ 7.6.6 using ? > update notepad++.

    on versions 7.6 to 7.6.4, or if you want to select your character encoding yourself, you have to go to settings > preferences > misc and disable autodetect character encoding, as seen at the screenshot below.
    settings - auto detect character encoding

    then go to settings > preferences > new document and set your default encoding to utf-8 and activate apply to opened ansi files.
    Imgur.

    note: if you copy/paste from a source like a browser, the special chars should appear correctly, but if you copy paste from an application, which uses a different character encoding, you will have to paste it into a new tab and switch through the different encodings, to figure out which ones they use.
    once you have done that, you can select encoding > convert to utf-8 before saving, or copy/paste the correctly displayed text from this scrap tab to your real file.

    best regards.



  • @Meta-Chuh Thank you for the answer, Unfortunately the updating solution has proved to be ineffective. And i had already used your other reccomendations in a previous attempt to fix the issue.



  • This post is deleted!

Log in to reply