Cannot run in Browser



  • I downloaded the npp 7.66 to my Windows 10 desktop and unzipped it there also.
    I looked at the shortcut. exe and it shows this for Chrome:

    <Command name="Launch in Chrome" Ctrl="yes" Alt="yes" Shift="yes" Key="82">chrome &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    

    so I am thinking this means I need to hold my conrtol, alt, and shift key down simultaneiously and them push the 82 numbers and Chrome should display my code in the chrome browser. That does not work, so can you tell me how I can get run to work with Chrome and other browsers? I have probably done lots of wrong things, but I used to be able to click run and be able to run in Chrome, etc. Can you help me straighten it out. Actually, I downloaded it onto desktop of 30 computers so that may be the problem. Thank you



  • @Toni-McDonough , Welcome to the Notepad++ forum.

    You said:

    so I am thinking this means I need to hold my conrtol, alt, and shift key down simultaneiously and them push the 82 numbers and C

    Nope. “82” is the ASCII code for the character you hit: R. So Ctrl+Alt+Shift+R is the key combo. That’s also seen if you look in the Run menu’s Launch In Chrome entry. Caveat: by default, v7.6.6 has the old run-menu-style “Launch in XXX” commented out in the XML. If it is commented out for you, it won’t show up in the Run menu, and the keyboard shortcut won’t launch the file in Chrome.

    The reason for that entry being commented out by default: Notepad++ v7.6.6 has a different location for a similar command, rather than relying on the entry in the shortcuts.xml and the Run menu, you can go to View > View Current File In… > Chrome. This will stay the same, regardless of config file.

    You can assign a keyboard shortcut from inside the Notepad++ interface, whether it’s via the old Run > Launch in Chrome or via the new View > View Current File In… > Chrome.

    1. Settings > Shortcut Mapper
    2. For the View version,
      1. pick the Main Menu tab
      2. filter on Chrome
      3. select Chrome
    3. For the Run menu version (this will ONLY work if it’s enabled in your shortcuts.xml and visible in your Run menu):
      1. pick the run commands tab
      2. filter on Chrome
      3. select Launch in Chrome
    4. after selecting one above, click Modify
    5. set the shortcut to whatever you want (watch for conflicts)
    6. click OK and/or Close until you’re out of the dialogs

Log in to reply