NppExec not being installed (though tried through Plugin Admins)



  • Debug info:
    Notepad++ v7.6.6 (64-bit)
    Build time : Apr 3 2019 - 23:52:32
    Path : C:\Users[my username]\Desktop\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : ComparePlugin.dll DSpellCheck.dll mimeTools.dll nppConverter.dll nppcrypt.dll NppFTP.dll

    Tried clean reinstalling and removing other plugins without luck.
    When I try to install NppExec, it prompts me that it will restart NPP but it doesn’t open again.



  • welcome to the notepad++ community, @kicKORhIT-16384-needSYDney

    nppexec usually installs fine on 7.6.6 x64 using the built in plugins admin.

    are you behind a corporate proxy server ?
    (e.g. can you run ping notepad-plus-plus.org in a cmd window, and get a response ?)

    why is your notepad++ installed to a folder on your desktop, instead of C:\Program Files ?

    do you get an uac prompt when trying to install nppexec from within plugins admin ?
    (i suppose not)



  • first, I just don’t like installing something (that can be portable) at Program Files, so I just installed NPP in a folder on my desktop :)

    also, I’m not behind any corporate proxy server.(pinging gives positive results, too.)
    I do get sorta a uac prompt, but that’s because I’ve set its level to highest



  • @kicKORhIT-16384-needSYDney

    if you like portable it’s perfect for testing:

    please test the following, to verify, if a clean notepad++ 7.6.6 x64 would be able to install nppexec.

    • download the notepad++ 7.6.6. 64 bit portable version from >>> here <<<.
      (the portable version does not require any installation and runs completely independent and isolated from your installed version. all custom settings, as well as any stuff you might want to try at the portable version, will not modify your installed version)

    • extract npp.7.6.6.bin.x64.zip to your desktop.

    • important note: make sure to close all instances of notepad++ that might be running, before starting the portable version at the next step, to be sure you are using the portable version for this test.

    • open the extracted npp.7.6.6.bin.x64 folder and start this portable version by double-clicking on notepad++.exe inside this folder.
      (note: notepad++.exe will just be seen as notepad++, if you have enabled to hide all known file extensions at your explorer settings)

    • open up plugins > plugins admin and install nppexec on this portable install for testing.

    note: if it works, and you don’t want to search for the culprit at your installed notepad++, just copy the npp.7.6.6.bin.x64\plugins\NppExec\ folder from the portable version to your installed Desktop\Notepad++\plugins\ folder.

    good luck



  • @kicKORhIT-16384-needSYDney said:

    I just don’t like installing something (that can be portable) at Program Files, so I just installed NPP in a folder on my desktop :)

    @Meta-Chuh replied:

    if you like portable it’s perfect for testing:

    The phrasing is ambiguous. If you try to do an install of Notepad++ to anyplace but Program Files, there is a tendency for things to not work quite right (*). If you just unzip the portable/zip/7z edition, then things will work right (but if you want Windows file associations, you have to do it yourself).

    If @kicKORhIT-16384-needSYDney really did an install, but to a non-Program Files location, that may be the cause of the difficulty.

    (*: I think it was back in the 7.6.3 or 7.6.4 days, but when I did my one attempt at install-to-non-Program Files, I think my biggest hurdle was that Plugins Admin wouldn’t show up. But that’s just my memory; it may have been during the dangerous-releases 7.6.0-7.6.2 when I last tried that… And now, since I’ve got my systems and file associations working the way I want them to, I don’t want to do an install which will confuse those.)



  • @PeterJones

    i’ve just installed notepad++ to C:\Users\User\Desktop\Notepad++\ out of curiosity, on a fresh vm, and notepad++ can install nppexec using plugins admin.

    what i do not understand is, if i look at the op’s debug info, there are other plugins installed.

    if i suppose they have been installed via plugins admin, because they are present and the op wrote specifically that nppexec can not be installed, not mentioning any other plugins not installable, i am really fascinatingly intrigued by that.

    let’s look forward to the outcome, or surprises of this issue, i’m very curious about that.



  • Strange.
    @Meta-Chuh , I unzipped the portable version to Desktop\NPP2 folder, ran the notepad++.exe, and tried installing NppExec.

    …and the same thing happened.(when i try installing NppExec(and only NppExec) NPP closes(after prompting for a restart), nothing happens. Manually opening NPP, there is no NppExec, and no NppExec folder in the NPP’s plugin directory.)

    It seems obvious that there’s something wrong on my side(not NPP) since Meta Chuh verified that he/she got it working, so…

    What more information would be helpful?



    • I’m not really sure if it was installed at first.
      The current 7.6.6 I’m using was updated (every time a new update came up) all the way back from 7.5.4, but since the portable version Meta-Chuh pointed me to showed the same behavior I don’t think this is an issue. Yes, I’ve removed all plugins, removed Plugin manager and installed the plugins with Plugins Admin.


  • @kicKORhIT-16384-needSYDney

    it might be a hosting issue and nothing wrong at your system.

    i believe it can have something to do with the nppexec download link provided in pl.x64.json which is the plugin list embedded in plugins\Config\nppPluginList.dll.
    this link does not point to a static resource, but to the load balancer page of sourceforge, which can result in a very long delay where gup.exe tries to download it, and eventually followed by a timeout.

    the link currently given is: https://sourceforge.net/projects/npp-plugins/files/NppExec/NppExec Plugin v0.6 RC2/NppExec_06RC2_dll_x64.zip

    are you able to download this manually from your preferred internet browser, or does it just show the sourceforge page without initialising an automatic download ?
    if you are able to download this, you could install it manually by extracting it to a newly created NppExec folder: plugins\NppExec.

    ps: as far as @Vitaliy-Dovgan has informed us about future nppexec releases, they will be available from github, with the file name NppExec_06RC3_dll_x64_PA.zipwhere the PA indicates the plugins admin releases.

    if the sourceforge link does not work for you you could also download NppExec_06RC3_dll_x64_PA.zip from github.

    good luck and keep us informed.

    best regards.



  • I think I’ve found the reason.
    Sourceforge is BLOCKED!!!
    Not just that page, but it’s currently unreachable from everywhere in where I live.
    So, this seems like a problem for our country’s censorship or whatever, not on Notepad++'s side.
    Which means…

    1. I can use the github link, so it would be my (temporatory) solution for the problem.
    2. …and here comes…
      since I’ve found a (perhaps serious?) problem on accessing sourceforge within our country, I should report this (if I find somewhere appropriate).

    To sum up, it’s a problem local to our country and not about NPP.
    thanks for all the help! @Meta-Chuh @PeterJones


Log in to reply