Double click on a not associated file calls uninstall



  • If I double click on a file that has no program associated I get a dialog asking How do you want to open this file?
    I then select Notepad++ and Notepad++ Uninstall is started!

    How do I fix this?

    I’m running Windows 10 and Notepad++ v7.6.6 32bit

    // Anders



  • All settings in this window

    Imgur



  • If I right-click and select Open with Notepad++ or double click on a registered extension everything works!

    But if I double click on a file that doesn’t have any program associated with it. Then you get a dialog (from windows) where you can select which program I want to use to open the file. If I here select Notepad++, the Notepad++ Uninstall.exe will start!

    The installation program has configured that the uninstall.exe should be used instead of notepad++.exe

    Anyone has a clue where this info is written (probably somewhere in the registry)

    PS! I running Windows 10 64 bits

    // Anders



  • I do not understand you well … maybe this topic will help you:
    https://notepad-plus-plus.org/community/topic/17571/windows-context-menu-turkish



  • This is an addition to my answer.

    Imgur



  • @Anders-Eriksson22 said:

    Anyone has a clue where this info is written (probably somewhere in the registry)

    Indeed, this seems to be a wrong configured entry in your machine’s registry.

    I guess somewhere in the past you double clicked a file with an unassigned extension and the dialog to select an application to open the file popped up. If this is done the first time after the installation of Notepad++ it doesn’t appear in the list of available programs.

    So you clicked the button to select a program by yourself. Presumeably in the file selector dialog you accidentally selected the uninstaller of Notepad++ to open the file. Your selection has been stored in the registry, thus the uninstaller shows up in the list of available programs now.

    You can check that by looking to the icon of Notepad++ in the list of available programs. If it shows a chameleon it is the uninstaller. Notepad++ itself is represented by a notebook and a pen.

    This can be fixed by a registry change. Open RegEdit.exe and navigate to HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command. In the right panel double click on the Standard entry and check its value. If it points to uninstall.exe change it to notepad++.exe.



  • @dinkumoil HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command has the value of %SystemRoot%\system32\NOTEPAD.EXE %1

    and all right-click and double click on registered extensions work! But file that have a file type of File, will start the uninstall program when double clicked on.

    File type

    How do you want to open this file



  • @Anders-Eriksson22 said:

    HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command has the value of %SystemRoot%\system32\NOTEPAD.EXE %1

    Are you sure you didn’t look at the HKEY_CLASSES_ROOT\Applications\notepad.exe\shell\open\command instead of HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command?

    it might also be in HKEY_CURRENT_USER\Software\Classes\Applications\notepad++.exe\shell\open\command, which is the per-user location for the same setting.

    File type
    How do you want to open this file

    FYI: you need to use the direct link copy from imgur to get the URL of the actual image, and then use the syntax ![](https://i.imgur.com/UvNNEeG.png) and ![](https://i.imgur.com/ZyMxFWf.png), which will embed the images as

    and

    looking at the “how do you want to open this file”, it pretty obviously shows the chameleon, which (as @dinkumoil explained) means it associated the uninstaller instead of the actual executable with the “open with” menu.

    Please re-check the registry in the locations that @dinkumoil and I have suggested.



  • @Anders-Eriksson22

    You can embed links to images into your postings. This way other users are able to look at your images without jumping to another website.

    Embedding image links works like this: ![Wrong icon](https://i.imgur.com/YC68GUE.png)

    The result is:
    Wrong icon
    This is the chameleon icon I’ve mentioned above. That means this list entry points to the uninstaller of Notepad++.

    This would be the correct icon:
    Correct icon

    Are you really sure that your HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command entry has the value %SystemRoot%\system32\NOTEPAD.EXE %1? I think you looked at HKEY_CLASSES_ROOT\Applications\notepad.exe\shell\open\command.



  • @PeterJones Yes, of cause I have looked at notepad.exe but there is no notepad++.exe there.

    In HKEY_CURRENT_USER\Software\Classes\Applications\notepad++.exe\shell\open\command there is no notepad++.exe but there was a uninstall.exe that pointed to the Notepad++ uninstaller. I removed this and now Notepad++ doesn’t appear in the How do you want to open this file list, but that is another problem.

    Thanks for the tip on how to make images embedded!

    // Anders



  • @Anders-Eriksson22

    I removed this and now Notepad++ doesn’t appear in the How do you want to open this file list, but that is another problem.

    thank you for your patience.

    to enable notepad++ in the open with list for your preferred file extensions:

    • close notepad++ if it is open

    • right click on your notepad++ desktop icon and choose “run as administrator”.
      note: if you don’t have a desktop icon in windows 10, click on the windows icon and right click on your notepad++ icon at the windows 10 start menu and select more > run as administrator.

    • make sure you see [Administrator] at the top bar of your notepad++ window, as seen at the screenshot below.

    • go to settings > preferences > file association and move your desired extensions to the registered extensions panel.
      (last panel on the right, as seen at the screenshot below)

    Imgur

    • hit close and exit notepad++

    • recommended: now reopen notepad++ normally, and go to settings > preferences > file association again, and make sure your desired extensions are also set for the standard user account.

    • then exit notepad++ again

    • right click on any file, that has an extension you have just set, for example a .txt file, and choose open with > choose other app and select notepad++ from this list.

    • optional: select always use this app to open .txt files and hit ok.
      (if you just want notepad++ to be in the open with list, but not set as default application, just press ok, without selecting always use this app to open .txt files.)
      your file should now open in notepad++.

    • optional: if you have selected always use this app to open .txt files:
      close notepad++ again and retry opening e.g. a .txt file by double clicking on it.

    best regards.



  • A big **Thank You **to all that has shared their valuable time and knowledge!

    This is the best thing about Internet!

    // Anders


Log in to reply