Error message closing find results window

  • Also, is there a way to correct the behavior that is displaying the ACK when trying to use the control key again? Having to close out completely is a pain…

  • @Zach-Mayfield ,

    Unfortunately, I’m not good at debugging crash issues… especially ones I haven’t seen.

    I’m hoping one of the others will be able to help you through debugging this.


  • @Zach-Mayfield

    please try a separate portable version of notepad++, to see if an absolutely clean and isolated notepad++ would work on your system.

    • download the notepad++ 7.6.6. 64 bit portable version from >>> here <<<.
      (the portable version does not require any installation and runs completely independent and isolated from your installed version. all custom settings, as well as any stuff you might want to try at the portable version, will not modify your installed version)

    • extract to your desktop.
      (copy from your download folder to your desktop, right-click on it, select extract all from the explorer context menu, and press extract to extract it to a folder called npp.7.6.6.bin.x64)

    • important note: make sure to close all instances of notepad++ that might be running, before starting the portable version at the next step, to be sure you are using the portable version for this test.

    • open the extracted npp.7.6.6.bin.x64 folder and start this portable version by double-clicking on notepad++.exe inside this folder.
      (note: notepad++.exe will just be seen as notepad++, if you have enabled to hide all known file extensions at your explorer settings)

    • retry with e.g. conducting a find all in current document search and closing your find result panel again.

    does this portable version work as expected ?

    best regards.

  • Meta,

    I’m still getting the error message in that version as well… Let me know what else you may need to figure out why this is happening. I appreciate it!

  • @Zach-Mayfield

    is this a normal Windows 10 installation?
    Meaning, it does NOT run under some virtualization environments like VirtualBox, Qemu, VirtualPC etc… ?
    What kind of mouse do you use?
    Did you install some mouse related driver software?

  • Standard Windows 10 install on a dell laptop. I had Logitech software for my mouse installed, but removed it to eliminate that as an issue, but I’ve had that installed for months.

  • @Zach-Mayfield

    could you try to resize the find result window and NOT to close it?
    Does the error happen again?

  • Resizing does the same thing. I can click within it and scroll through the find window. But if I touch anything involving the title bar of the find window, the error comes up.

  • What happens if you double click the title bar, to make it floating?

  • If I double tap, I can close and move around without a problem. I can re-dock it and I don’t have the problem. If I close it out, go back in and generate the find window docked, the error is there again. I did use the portable one for testing.

  • @Zach-Mayfield

    I’m wondering, does this also happen when you are using two views and resize them?
    Or any other docked window other than the find in result window?

  • Dual views are fine. I did get the same error with functions list, that docked on the right. However, I got the error after trying to move the window after double clicking on it to undock it.

    Document Map behaved when docked, but not after undocking it😔

  • @Zach-Mayfield

    By any chance, did you recently update/upgrade any driver (any, not only mouse driver) or antivirus software?

  • No recent software updates. Antivirus is updated regularly by our IT department. Several others use notepad ++ and they haven’t been having this problem. And they would have the same updates I would have.

  • @Zach-Mayfield

    running out of ideas and it is already 01:00 here.
    If no one else finds the culprit, I try thinking about it after a good sleep :-)
    One last question for now, all the tests were done with the portable version, right?

  • Correct :) I stopped touching my install once I was given the portable version to make sure it was a clean install as suggested.

    I appreciate your ideas! I guess I will put my laptop away for now. Hopefully someone else has some ideas.

  • Worked with our IT team. discovered it was our Antivirus software blocking the current version of Notepad ++. They stated that the vendor isn’t listed on the EXE and wasn’t digitally signed for it to verify it’s authenticity.

  • @Zach-Mayfield

    good to hear that.
    the next release (7.7) will be code signed again.

    a little warning: 7.7 is a major upgrade jump of the integrated scintilla editor engine, as well as the boost regex engine, so we expect some unknown issues yet to arise, while some others, depending on old engine’s issues, will be fixed.

    many thanks and best regards.

Log in to reply