Double click on file fails



  • Changed to 32 bit to keep ColdFusion Lexer.

    Notepad++32 works from program menu fine, no problem.

    Clicking on associated file starts notepad++, but quits immediately.

    Context menu “edit with Notepad++” fails same way.

    “Open with” gives Notepad++ option, it fails same way.

    “Open with” “New App” does same.



  • Welcome to the Notepad++ Community, @micstan.

    I’m sorry things aren’t working for you. However, you didn’t give us much to work on.

    My guess is either that you’ve got an unstable plugin, or that your program menu “notepad++” isn’t pointing to the same copy as the association / “edit with notepad++” / etc…

    Please supply the following information

    1. When you run from program menu, please use Notepad++'s ? menu, select Debug Info, and Copy debug info into clipboard, pasting it here.
    2. In the program menu, right click on “notepad++” until you see the properties entry, then select that. Copy/Paste into here
    3. WinKey+R, regedit, ^F to search for with Notepad++ in keys/values/data; when it finds one, go into the subkeys to find the command subkey, and share with us
      • I expect there’s probably some instance of the Notepad++ associations in one or more of the following locations, or a subkey of one of these:
      • HKEY_CLASSES_ROOT\*\shell\Notepad++ (might be under a slightly different name than Notepad++)
      • in HKEY_CLASSES_ROOT\.txt, look at the value in the (Default) entry… (for example, XXXX) then go to HKEY_CLASSES_ROOT\XXXX\shell
      • HKEY_CURRENT_USER\Software\Classes\*\shell\Notepad++ (might be under a slightly different name than Notepad++)
      • in HKEY_CURRENT_USER\Software\Classes\.txt, look at the value in the (Default) entry… (for example, XXXX) then go to HKEY_CURRENT_USER\Software\Classes\XXXX\shell
      • If you find any or all of those, show us the command value(s)


  • Removed it and reinstalled 7.7x32 didn’t help. removed and installed 5.86, worked, upgraded several iterations, at 7.7 problem reappeared. Copied my preferences, plugins, etc. to a safe area. Completely removed it, deleted folders, went through regedit and deleted all reference to notepad++. Worked up to 7.5.1 and only a minor issue with the old Coldfusion plugin that I had fixed before. I can work at it again or ignore it for the time being. The ColdFusion plugin is probably part of the problem and me forcing x35 may have messed up the “edit with Notepad++”, it appeared that there was enough of x64 left in the registry that windows was trying to start the x64 but only finding the x32 and could not keep it running.

    Thanks…


Log in to reply