NPP crashes when opening UNIX file with "NULL" chars on it

  • Hi,
    I just transfered a UNIX file to Win, and tried opening it with NPP. It stayed in a blank page saying “opening” until I closed it. Never opened it.
    Checking the file with vi/cygwin in Windows, it was indeed a readable ASCII file, but with \000 chars on it (NULL).
    I removed those chars, and it worked.
    But I wonder… should this cause NPP to crash? Maybe a warning, and displaying the file ignoring those NULL should be the right option.

  • welcome to the notepad++ community, @Leo-Lagos

    no, notepad++ should not crash, if a file contains 0x00 characters.
    maybe it’s a plugin like the dspellcheck plugin that causes this ?

    please test the following, to verify, if a clean notepad++ (without any plugins that could cause this) would work on your system.

    • download the notepad++ 7.7 portable version from >>> here <<<.
      (the portable version does not require any installation and runs completely independent and isolated from your installed version. all custom settings, as well as any stuff you might want to try at the portable version, will not modify your installed version)

    • extract to your desktop.

    • important note: make sure to close all instances of notepad++ that might be running, before starting the portable version at the next step, to make sure you are using this portable version.

    • open the extracted npp.7.7.bin folder and start this portable version by double-clicking on notepad++.exe inside this folder.
      (note: notepad++.exe will just be seen as notepad++, if you have enabled to hide all known file extensions at your explorer settings)

    • try to open the original unix file containing 0x00 characters.

    many thanks and best regards.

Log in to reply