Cannot open .txt files with NP++ v 7.7.1 (64bit) on Win 10 version 1903



  • Hi NP++ team,

    Been a regular use of NP++ since several years for regular tasks but now on the new Windows 10 install of version 1903, I am unable to use a freshly installed NP++ v7.7.1 64 bit program to save or even open any workable .txt files.

    1. If I compose a new file and save on desktop,it is saved as an unrecognized file format and double clicking it asks me what program I want to use to open it. The program list contains Windows Notepad and wordpad only,.

    2. Right click on an existing Windows Notepad file does give me an “edit with NP++” option and it works fine.

    3. If I try to change the default program for Windows notepad created .txt files to NP++, don’t see any way I can do it, just cannot ind NP++.

    This has always worked on Windows 7 and even 10 previous versions with a clean NP++ install, without any tweaking the registry. Why the issue now?

    Please assist. Am I doing something wrong?



  • Resolved but NP++ team needs to fix this now.

    I installed a forked version from Microsoft store or NP++ (version 7.5.9 64bit) and that fixed it!

    Looks like both 32 bit and 64 bit versions of 7.7.1 have the issue where the file is not saved as .txt by default, even if you try to double click a .txt file, created by manually opting for .txt extension from NP++ it gives a program error and asks to choose the program to open that file. Right clicking on the existing .txt file does not give an option to change the default program to NP++.

    All issues fixed with the forked older version. Hope NP++ developers get this looked at and ixed.



  • @pravin-nehete

    looks like a new style dialog issue. Check if settings->preferences->default directory->use new style… has been set.



  • Nope that does not fix the file association issue. I have the settings -> preferences -> default directory -> use new style dialog checked

    My problem is similar.

    Had win10 1809. Updated our master images to 1903. Noticed that .txt was not being set properly (we use defaultappassociations.xml file to do this on the domain).
    Updated notepad++ to latest version (7.8.1) and pushed to clients.
    Still does not associate correctly.

    On 1809 clients it works fine still, with the same application association file.

      <Association Identifier=".txt" ProgId="Applications\notepad++.exe" ApplicationName="Notepad++ : a free (GNU) source code editor" />
    

    I know m$ is screwing with you guys, but maybe there is something you have to do on your end to make notepad++ compatible with 1903?
    i cant deploy from the microsoft store currently so that other fix wont work for me.



  • @igitthatalot said in Cannot open .txt files with NP++ v 7.7.1 (64bit) on Win 10 version 1903:

    i cant deploy from the microsoft store

    This is a good thing as the M$ store version is considered a “renegade” version (actually, just a “fork”) and is not supported here.



  • any update on this dev team? just tried 1.8.4 and no dice. it does not appear as an application until after you open it onetime, and then only for the current logged on user, not all users on the machine.

    I think notepad++ needs to be registering itself as an application. If i can figure out how to do that i will post back, but its probably something you guys will need to fix.


Log in to reply