All file content is replaced by ÿ. The entire file is filled with that character. the format is ANSI but default is UITF-8. How can I fix it?



  • ANSI UITF-8 Replace



  • If you make a change, and it’s not what you want, hitting UNDO should undo whatever you did… or unloading and reloading the data (assuming you hadn’t saved). If you’ve saved the bad data to disk, things are going to be harder to get back. You will probably need to search through your backups (or, if you haven’t been backing up your data, you’ll have to try to find file recovery software.)

    As to debugging the problem that caused the replace-by-ÿ:

    Please see the FAQ at https://notepad-plus-plus.org/community/topic/15739/faq-desk-request-for-help-without-sufficient-information-to-help-you

    After reading that FAQ, please describe your situation in more detail: what did you do that resulted in everything being replaced by ÿ? more details about what you started with, and what you were trying to achieve, would be helpful as well. (Not forgetting to provide other information, as described in that FAQ, especially the version and debug info)

    If you’ve got a repeatable sequence of events, staring with known sample data (it doesn’t have to be your proprietary text; just dummy text that will show the same problem), following steps X, Y, and Z, expecting WVU but getting all ÿ’s, then it will help us replicate your problem on our to try to figure out what’s gone wrong.

    (BTW: the encoding name is UTF-8. I am not sure if that’s what you mean by “UITF-8”. But you’ll need to use clear terminology, to make sure that we don’t misunderstand you.)



  • Sorry about that. Here is what happened.
    I have a text file where I stored all my password. I used n++ to maintain the file. I stored that file on mini SD card so no online back up available. That is the only copy. About two weeks ago I moved all my files from SD card to WD MyPassport Ultra 1TB external drive before going on vacation. Today when I tried to open the file all I see is ÿ character repeated. It shows ANSI on the bottom right of the file so assuming that the file encoding is ANSI. I also tried to open file in Notepad and it shows the same character repeated. I looked up online and someone suggested to try BabelPad. I opened file in BablePad and it shows blank.



  • Thank you for the extra details.

    So, it sounds like at some point – either on the mini-SD or in the transfer from the SD to the WD MyPassport Ultra, or after it was on the WD device – the file got corrupted. The ÿ character is at codepoint 0xFF in “ANSI”, which is all 1’s in binary. That sounds like a network or device communication error to me, and is probably not related to Notepad++ itself. (*: in the past, a crash or other strange network event has caused old versions of Notepad++ to write all 0s [NULL], but I’ve never heard of it writing all 1s. If you’re using the newest v7.7.1 – or at least v7.5.9 or newer, the all-NULL bug should be fixed.)

    As I said, if you don’t have a backup of the file, you might look for file recovery software. I think one suggested in this forum was “recuva” (suggested at least here) – I have no experience with nor make any warranty regarding its effectiveness in your situation. If you still have both the SD card and the WD drive available, I would try the recovery software on both.



  • Thank you for your response. It looks like I lost the file at this point. I tried Recuva but it doesn’t even recognize the file.


Log in to reply