Save Files



  • Notepad++ won’t save my files as a specific file type.

    I am trying learn some JavaScript, and now when I create my own file, and go to save it as a JavaScript file, it won’t do it.

    When I close out of Notepad++ and go straight to my the file I previously selected where I know I selected the .js extension, it opens it as a plain text document, and doesn’t do anything. When I go back to “Save As,” rename the file, and again select the .js extension, it doesn’t do a thing about changing the file type.

    I used to be able to save as different types of programming language, but now no matter what file type I try to “Save As,” I get the same result of a generic “all type” file.

    I can’t use this editor if this is what is going to happen.



  • You may want to try toggling the Settings > Preferences > Default Directory > Use new style dialog. Some Windows users like the behavior of Windows’ old-style file-open/save dialog boxes, where if you select a specific file type for filtering, it will auto-add an extension, overriding whatever extension you happened to type (or giving it an extension if you neglected it). With the new-style Windows file-open/save dialog boxes, Windows understands that it’s safer to not rely on automatic extensions, because when you select C++ source file (*.h; *.hpp; *.hxx; *.cpp; *.cxx; *.cc), how can Windows or Notepad++ know which of those six extensions you want applied to the file.

    See also my comments in this recent topic. See also Settings > Preferences > Default Directory documentation.

    Please note my emphasis on the word “Windows” here. Notepad++ makes available two different standard Windows dialog boxes – the behavior of both is defined by Microsoft Windows, and not by Notepad++. If you dislike the behavior of the dialog, it’s a Windows problem, not a Notepad++ problem. Fortunately, Notepad++ gives you access to both styles of dialog boxes, unlike most programs, which just give you access to one (whichever happened to be in vogue when the app was released).



  • It still is not working.

    I still cannot save the file as anything specific, and this causing problems when I am trying to code. I toggled the “Use new style dialog,” I closed out of Notepad++, I uninstalled and reinstalled it, and nothing is working. I followed your posting on the second link, and still I am getting the same problem where nothing is working as it ought.

    Even now when I save the file, and I select the .js extension, it does nothing to the actual file. I type in the file extension, nothing. I can close the editor, navigate back to the file, and open it is specifically in Notepad++, and I still have just a plan text document without any language settings on it, and no way to make any type of file that I need to make.

    So, I am going to find a new editor. I appreciate your help, but this is no longer worth trying when there are other editors that work.



  • @Kyle-Christian said:

    It still is not working.

    After the description of what you’re doing, I disbelieve that it’s not working. My guess is that you’ve still got Windows hiding extensions, so you don’t notice the extension is actually there.

    So, I am going to find a new editor

    That’s not going to help if you’re not using Windows properly. And even if it’s something else, it won’t help when you come across some behavior in that program that you’d rather not figure out, or something that you think is that program’s fault, but is really the fault of Windows or something you’ve just not done correctly. Good luck with that long term.

    if you’d like continued help here, feel free to ask, and we’ll be happy to help you learn. Otherwise, good luck.


Log in to reply