Notepad++ File Association vs. No Authenication



  • Version: 7.7.1

    I associate a few file extensions (.TXT included) with Notepad++. When I click on a file that contains one of the associated extensions (like .TXT), the launch of Notepad++ encounters an authentication error. How can this be avoided?

    Randy Reist



  • Hello, @Randy-Reist

    To resolve your issue, please follow these steps :

    Step 1:- Open notepad++
    Step 2:- Click on Settings menu
    Step 3:- Select Preferences
    Step 4:- Select File Association
    Step 5:- In “Supported extensions”, click "Notepad"
    Step 6:- The next panel to the right, you should see the .txt and .log extensions.
    Step 7:- Click on .txt extension
    Step 8:- Click on “->” (right arrow) to move .txt to "Registered Extensions"
    Step 9:- Close the Preferences window
    Step 10:- Use File Manager and navigate to a directory with a .txt file in it.
    Step 11:- Right-click on .txt file
    Step 12:- Select Properties
    Step 13:- Open box in “Opens with:”,click the “Change” button and select Notepad++
    Step 14:- Click on OK button

    Now Notepad++ is default app for .txt files.

    I hope above information will be useful for you.
    Thank you.



  • @Randy-Reist said in Notepad++ File Association vs. No Authenication:

    authentication error.

    Authentication errors in Notepad++ sound like a proxy issue. See this topic for how to set up Notepad++ to properly see your proxy. Unfortunately, there are some proxy configurations that NPP doesn’t handle. You may have to turn off the auto-updater, and manually install updates and maybe plugins as well.


Log in to reply