Notepad++ Portable FTP Unable to Connect



  • I was able to use FTP to edit and upload a file to my Hostinger website using the NPP FTP plugin. I then installed Noepad++ Portable on a USB drive and was able to upload as before. Now I am using the NPP Portable on a different computer (to which I don’t currently have admin access) and FTP fails with the responses:

    Connecting
    -> Quit
    Unable to connect
    Disconnected

    I tried creating anew profile on this PC but it didn’t help. I also tried all the Connection Types in the FTP profile. I suspect it could be a firewall issue (Windows 10). The computer doesn’t seem to be running any anti-virus etc software except for Windows Defender.

    Thanks in advance
    Ron Besdansky



  • @Ronald-Besdansky

    I do not use the ftp plugin so can’t be of help in that case but
    what about pinging your host and using ftp from cmd shell?
    If that is working, it must be a plugin issue otherwise, as you already assumed,
    it seems to be an OS/access rights issue.



  • @Ronald-Besdansky ,

    To make sure I’m clear: you had a portable USB drive that was working, you moved that same USB to a different computer, and it didn’t work there? All the settings were the same, and you didn’t have to re-configure NppFTP? If so, that really does sound like a computer issue (or something about the computer influences the plugin, as @Ekopalypse suggested), which we’re not likely to be able to diagnose remotely. Firewall or proxy settings would make sense to check.

    As an alternative: I frequently use a combination of FileZilla with Notepad++: I use FileZilla for doing the SFTP (because it can handle a wider variety of circumstances on the server than NppFTP can, due to choice of underlying SSL library used in FZ vs NppFTP); I set up FileZilla to use Notepad++ as its editor, and then do the FileZilla RightClick > Edit to do the editing on the "remote
    file. So assuming you can connect with FileZilla when NppFTP cannot, that might be a workaround for you as well.



  • Thanks for your replies. I tried using ftp from a Windows command prompt to upload my file but it was blocked by the Firewall. That’s presumably why the NPP Plugin was failing, although it wasn’t saying what the problem was.

    Thanks again
    Best wishes
    Ron B


Log in to reply