Suddenly cannot type [ in Notepad++



  • Cannot type [ in notepad++. It collapses the current level of code instead - it does the same as Ctrl Alt F. Right bracket ] normally just types it. I have no idea how this happened. It was working well before! Could I do it somehow accidentally? How can I fix this?

    I looked into Settings > Shortcut mapper but the mappings of the Collapse function seem allright:

    alt text

    I posted my question here as well, feel free to respond there: https://superuser.com/q/1501006/93604



  • @Tomas-T

    I guess you use a czech keyboard, don’t you? So, to input [ you have to press Alt GR + F. Unfortunately Alt Gr internally is the same like pressing Ctrl + Alt. Thus Alt Gr + F is the same as Ctrl + Alt + F what is mapped to Collapse Current Level.

    You should remap Collapse Current Level to another keyboard shortcut.



  • Had the same problem today, 07-Dec-2020

    Initially thought there was a problem with the Keyboard, or some gaming settings had come on. But found that it was typing normally in every other program.

    Finally found the problem. It seems that I had accidentally pressed some key combination that had activated a shortcut that made the file Read-Only.

    Fiddling around, found a setting in Edit Menu. And removed the Read only status.

    Everything was normal immediately.


Log in to reply