How to eliminate the blinking spell check/suggestion popup? Notepad++ 7.7.1



  • I can’t seem to find the answer to how to turn off that annoying popup when I’m typing a letter or taking notes? Flashing and blinking trigger migraines.

    I have Windows 10 and Notepad++ Version 7.7.1.

    Notepad++ is my favorite/only Windows text editor, used it for years with Windows 7.

    Whatever I did to get rid of that blinking popup in 7, I can’t find a solution for Windows 10, anywhere. Please help?



  • I am assuming you are talking about the auto-completion feature, and the Settings > Preferences > Auto-Completion settings that affect its behavior. Hopefully those links will help you turn off that feature.

    If that’s not it, you’ll have to explain better what you’re seeing, because I don’t know what’s “blinking” about that auto-completion feature.

    Also, since you call it “spell check”, do you have a separate spell-check plugin running / enabled? If you go to the ? menu, and choose Debug Info > Copy debug info into clipboard, and paste it into your reply, we’ll be able to see what plugins you have, which may or may not be causing the “blinking”.



  • Hello, @Linda-Hull

    Follow these steps to add spell checker on notepad++:

    Step 1:- Go to the Plugins menu.

    Step 2:- Select Spell-Checker and inside of spell-checker select How to use…
    Note :- If Spell Checker isn’t shown in the list, open the Plugin Manager and check it from the available tab and then click Install.

    Step 3:- Now follow the link in How to use… window : http://aspell.net/win32/

    Step 4:- After opening link in browser select Full Installer under Binaries : and download the file.

    Step 5:- Then under dictionary select aspell-en-0.50-2-3.exe and download that file.

    Step 6:- Run the first downloaded file, it’s full name should be Aspell-0-50-3-3-Setup.exe and installation is simple, just click Next a bunch of times.

    Step 7:- Next, install the dictionary file. It has the same type of setup click next until it is done.

    Step 8:- Now exit and restart Notepad++.

    Step 9:- Now open Plugins menu .It will have different options. Click on the Spell-Checker . You can also use Ctrl + Alt + Shift + S as a shortcut for this.

    Step 10:- Open spell-checker dialog and it will find the match, except that spellcheck is automatically hunting down words that don’t match its dictionary.

    I hope above information will be useful for you.
    Thank you.



  • @PeterJones Thank you! You understood me. Turning off the auto-completion, did it :)
    Regards the ‘blinking’: Every word and letter I typed caused the popup to come up or changed it. I like things to hold still, on my screen.

    Linda