Problems with configurator & style loading at StartUp



  • Since updating my Notepad++ to…

    Notepad++ v7.5.9 (64-bit)
    Build time : Oct 23 2018 - 22:14:15
    Path : C:\Program Files\WindowsApps\NightRise.NotepadWrapped_7.59.32.0_x64__bahp16nyyek9m\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll ComparePlugin.dll MarkdownViewerPlusPlus.dll

    …, whenever I try to open it by clicking on document endings like .txt, .html, .php etc. (which I have configured to be preferred formats), the following info pads appear:

    1. “Configurator
      Load langs.xml failed!”

    As soon as I press the OK-button supplied, a second info pad appears,

    1. “Load stylers.xml failed
      C:…\AppData\Roaming\Notepad++\stylers.xml”

    About 15secs after pressing the OK-button supplied by this second info pad, Notepad++ opens. Even if already opened, this sequence repeats with every new document I want to open. Quite annoying.

    I have already tried to remove the program entirely and installing it as a completely new application - same result.

    Could anybody help me to get rid of this behavior? Otherwise & once opened, my Notepad++ is working fine. Opening documents from the internal menu point “open” is working flawlessly, too, The previous version was working without any similar problems right from the first installation.

    Tnx in advance and cheers,
    Leo



  • @meincoach

    First of all, you are not using the official notepad++ (npp) version but a fork which was created to add npp to the windows store.
    Unfortunately that meant, that certain functions aren’t allowed, like the run feature as far as I know, which means there was a need to change the source code.
    If those changes are responsible for your problem, I don’t know as I don’t use this version.

    In order to see if the same problem appears when using the official version, I would ask you to download a portable version,
    aka a zipped, from here.
    Just unzip where ever you want and run it. There is no need
    to deinstall your current version just for testing, it might be needed to close your installed version in order to be able to run
    the portable version. Depends on your configuration.

    Note, since version 7.6 and again with 7.7 there were a lot of changes,
    specifically how plugins are loaded and the underlying scintilla component was updated,
    which, again, had strong impact on plugins using it.



  • Tnx a lot for your most helpful repy. Installation (v7.8.1., though 32bit-version) completed smoothly, no problem.

    However, I do not succeed to declare it as a standard App (to open e.g. .txt-files automatically instead of the editor etc:) - it simply does not appear under any of the choices given by WIN10. What do you suggest?

    Tnx in advance for your support.



  • @Ekopalypse
    I have installed the 64bit-version of v7.8.1. now, but still do not find the program under standard apps, thus automatic opening e.g. .txt-files, still doesn’t work.



  • @meincoach,

    I have installed the 64bit-version of v7.8.1. now

    So, it sounds like you used the full installer, and are focusing on a different problem now, rather than downloading the zipfile, so @ekopalypse could help you debug your original issue.

    For default file associations with Windows 10, the following sequence worked for me: I spun up a brand new Win10 virtual machine, because I’m particular about my installations of software on the machine I actual use; this environment thus mimics a brand new installation, with no cruft from previous installations of Notepad++ or faux-forked-Notepad++.

    • (if you have any other copies installed, uninstall them all, and preferably clean out registry so there is no hint of them remaining)

    • run fresh installer .exe from https://notepad-plus-plus.org/downloads/v7.8.1/

      in theory, you are at this state already. but you have been trying lots of stuff, so who knows.

    • RClick on blah.txt

    • Open With

    • Choose Another App

    • More Apps

    • Look for Another App

    • Browse to your correct installation of Notepad++ and select OK

    • file should be loaded in Notepad++

    • Close file.

    • Close Notepad++

    • RClick on blah.txt

    • Open With: Notepad++ should be in the list… but ignore that for now

    • Choose Another App

    • select Notepad++ (but don’t hit OK yet)

    • enable Always use this App

    • OK

    • Close file

    • Close Notepad++

    • blah.txt should use Notepad++ icon, and double-click should load Notepad++ now



  • @meincoach
    File associations can be added manually.
    Doesn’t that work for you?

    Imgur


Log in to reply