Disconnect on save with latest NppFTP



  • I’m at my wits end searching for a solution to this problem. A few days ago I was prompted with an update to Npp which caused this problem to start:

    When connected to a server via SFTP I am able to open files and navigate perfectly fine, but simply clicking the save button causes me to disconnect. The NppFTP output reads only:

    [NppFTP] Everything initialized
    Connecting
    [SFTP] Host key accepted
    [SFTP] Successfully authenticated
    Connected
    save
    Disconnected

    I am able to push changes via the upload current file function, but it’s extremely inconvenient.

    I have tried the latest and previous versions of Npp, both 32/64bit versions, and the two latest versions of NppFTP, 3.0.1 and 3.0.2, and connecting to a different server (which also worked happily previously) but no configuration changes the behaviour at all.

    I hope someone has encountered this before!



  • I’ve solved my own problem. It looks like a weird bug. I had the hostname set to username@hostname, so somehow I was connected to username@username@hostname which apparently works fine but something goes wrong when you save.

    Please don’t ask how I managed this.


Log in to reply