How to set "Font Name" for specific language?



  • Hello dear friends!

    I have lexer called AutoHotkey Black.xml I’ve set up keyword fonts for him.

    …Language > User Defined Language > Define your language… > Comment & Number > Comment line style > Font Options:
    Name: Consolas
    Size: 7
    Foreground color: #71AE71

    …and also examples:

    … > > > Keywords Lists > 2nd group:
    Name: Trebuchet MS
    Size: 10
    Foreground color: #0060FF

    … > > > Keywords Lists > 4nd group:
    Name: Fira Code
    Size: 8
    Foreground color: #808000

    However, there may be other different text in the file and it looks lousy because there is no font installed for them!
    That’s how it’s gonna work out:

    menu > Settings > Style Configurator… > Font Style > Trebuchet MS

    But the font is set for all languages globally! In this window I don’t have language as AutoHotkey:
    AutoHotkey

    !! I want the font to apply to the whole code except for keywords. Any ideas on how to solve the problem?



  • @Сергей-Друзь said in How to set "Font Name" for specific language?:

    I want the font to apply to the whole code except for keywords. Any ideas on how to solve the problem?

    If I understand correctly, then don’t mess with global styles.
    Define your DEFAULT style of the UDL LANGUAGE

    d0e361ff-289e-4697-8ac1-1b207d34827d-image.png


Log in to reply