Don't spin up HDD on startup



  • Every time I open N++, even with no open file in the current session, my HDD spins up. Some files in the recent list are on that HDD, but I have checked “Don’t check at launch time” in Settings > Preferences > Recent File History.

    Anyone else experienced this, or knows how to prevent HDD spinning up when launching N++?

    DEBUG INFO ===========================
    Notepad++ v7.6.4 (32-bit)
    Build time : Mar 6 2019 - 02:52:22
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll



  • Is the notepad++ executable, or your %appdata% folder, on your HDD? If so, Windows has to spin up the HDD in order to read the executable file or the configuration files.



  • Of course it is not on the HDD



  • There is no “of course” in this forum, or any other place where people ask for help.

    You’re using an older version. I vaguely remember that there was a bug with “Don’t check at launch time” sometime in the last year or two. You might check if the newest v7.8.2 has the same problem (you could download the portable zip, and unzip and run from a non-installed but non-HDD folder for checking). If not, then you can either switch to v7.8.2, or (if there’s something else making you want to stay on v7.6.4), then you will understand that your choice to stay on v7.6.4 is what’s keeping that HDD spinning.

    If newer version doesn’t fix the problem, then there may be some other reason that Notepad++ is looking on the HDD (or that Windows is looking on the HDD when it launches Notepad++). In which case, I am out of ideas.



  • @plazer1 Install ssd … and everything will work without noise - :)



  • @andrecool-68 ,

    Install ssd

    I have been working under the assumption that that’s what @plazer1 has done: according to the assertion that notepad++.exe and %appdata% aren’t on a HDD strongly implies that they are on a SDD, and that @plazer1 has data on the larger HDD, but is trying to avoid having the data HDD spin up when Notepad++ runs from the SDD. (Not every data HDD can be economically replaced with equivalent storage of SDD.)



  • @PeterJones said in Don't spin up HDD on startup:

    I have been working under the assumption

    Contributing to the difficulty in providing an answer, or doing further investigation, is the fact that @plazer1 is providing very little detail. Maybe doesn’t like typing. I don’t really like typing either, but when I’m asking for free help, I’m willing to go the extra mile…



  • @Alan-Kilborn Is there some particular information you’re missing? I can tell you this, which I thought was obvious enough to moderately intelligent people: my Notepad++ is not on the HDD, nor are any of the configuration files, or any files open in the Notepad++ session. If you need more information, I’m afraid you will have to ask for it since I’m not able to read your mind, neither am I familiar with this forum. I was precautious enough to include debug info; I thought that would provide more than enough detail.



  • @PeterJones Thanks, I’ll try the newer version



  • @plazer1 said in Don't spin up HDD on startup:

    which I thought was obvious enough to moderately intelligent people

    I guess PeterJones and I are among the class of people known as brain-damaged. Strange how we are #1 and #2 in reputation points on this forum, you know, being as dumb as we are.

    BTW, good luck with your problem.



  • If you have enough expertise you may use advanced tools like Process Monitor.
    It will enable you to find the exact files on the HDD which are accessed by Notepad++ on startup.
    Knowing the files will make it much simpler to root cause the issue.



  • Hello, @gstavi,

    Reading your post to @plazer1, I decided to give it a try ! So, I saved all events, detected by Procmon, regarding the Notepad++.exe process, in a log file, when Notepad++ starts-up !

    Note that my N++ 7.8.3 configuration works fine !! So, it’s just a test and not a debugging task !. However, if you don’t mind, I would like to send you this small log file ( ~840 Kb ), with few comments of my own !

    My e-mail address is tguy.038@gmail.com

    Again, I’m not requiring any help from you, but I just curious to know your feelings about it, as your knowledge of the Procmon utility is, of course, much better than mine.

    Thanks by advance !

    guy038


Log in to reply