Install button is greyed out?



  • Hi, no matter what I try the install button is always greyed out. I’ve tried the 32-bit version and the 64-bit version. I can open Plugin Admin, I can see the full list of plugins, I can click on them and view the infos. But for every single plugin the install button is greyed out and I can’t click it. I can easily install them manually but this is driving my ocd crazy and it’s really annoying me. I’ve tried adding Notepad++ to my firewall exceptions and my anti-virus exceptions. I’ve tried adding a proxy address but I don’t know what to set for the port number… I tried port 8086 but it returned an error. I tried re-installing and restarting the pc but had no affect. I tried running in admin mode, no dice there. I don’t know what else to try. I’m on Win 7 64-bit and Notepad++ is installed on a different hdd than C drive.



  • @munchies34

    Proxy address and port are going to be set by your local I.T. department. They aren’t specific to Notepad++, so you’ll have to find out what they are. If you aren’t behind any I.T. department it means YOU are the I.T. department, so you’ll have to figure out what you have set up (good luck).

    But yes, once you know the correct numbers, you have to run Notepad++ in administrator mode in order for this setup to matter:

    160698ff-1d01-4e04-a29a-cd2ab66312e9-image.png

    Obviously! don’t copy my zeros thinking it will work for you. :)



  • @Alan-Kilborn Hi, thanks for replying. Okay, I understand all that but I don’t know what to set for the port. And I know the ipconfig / netstat commands but I have no idea what I’m looking at. I just see a soup of numbers. Why can’t this be easy??



  • @munchies34 said in Install button is greyed out?:

    I don’t know what to set for the port

    If your local I.T. department set up a proxy, ask them for help (they would know how they configured the proxy)

    If you don’t have a local I.T. department, but someone else set up a proxy, ask that someone for help (they would know how they configured the proxy).

    If you are your own I.T., and you set up a proxy, go look at your proxy’s configuration to figure out what port.

    If you are your own I.T., and you didn’t set up a proxy, changing proxy settings in Notepad++ isn’t likely to be helpful to you.



  • @munchies34 said in Install button is greyed out?:

    I can see the full list of plugins, I can click on them and view the infos. But for every single plugin the install button is greyed out and I can’t click it.

    Back to your original question:
    I played around with the Plugins Admin a bit (no proxy!), and what I saw was that “click on” can have two different meanings. One leaves the Install button grey, the other activates it.

    1. Clicked on, but grey:
      ef7d6636-6c05-4788-a4aa-cfa82d12334e-image.png

    2. Clicked on, and active:
      a63af1ac-8585-4cf7-ba25-af9b5cff9b2d-image.png

    When you say “click on”, did you mean you clicked on the text, or you clicked on the checkbox and enabled it?

    You need the second variant to be able to install. (And you should be able to enable more than one simultaneously for multiple-plugin installation.)

    It would be helpful to have a screenshot of your Plugins Admin when you feel you should be able to Install, but cannot. Just hit Alt+PrtScn in the dialog, then Ctrl+V in your reply here.

    If checking that box isn’t sufficient for you, please go to the ? menu (right side of the menu bar, next to Window), and Debug Info entry, click Copy debug info into clipboard and paste into your reply as well.



  • @PeterJones Lol I feel stupid. Yes, clicking the box fixed this issue. Thank you! Maybe if I can make a suggestion to put some text somewhere explaining to check a box. That might help someone who was as confused as I was. Thanks again for the help.



  • @munchies34 said in Install button is greyed out?:

    Maybe if I can make a suggestion to put some text somewhere explaining to check a box.

    Feature requests cannot be tracked here. Follow the FAQ for requesting a new feature


Log in to reply