Zen coding plugin problem solved



  • Just in case this helps someone else with the same problem:

    I just made a fresh install of NPP 7.8.4 32 bit on a new W10 machine. I then started on installing plugins, using “Plugins admin…” and ran into a problem with the Zen coding plugin (yes I did install the python script). The menus looked ok, but when I tried to use a Zen coding command, keyboard short-cut or via the menu, nothing happened.

    After some Googling and thrashing (I am not familiar with the plugins interface) I came across this post (https://sourceforge.net/p/npppythonscript/discussion/1188886/thread/584dc8c4/) on a related matter. So I looked to see where the plugin manager had put the ZenCodingPython directory on my system. It was under the “ProgramFiles (x86)” folder. I tried copying it across to %APPDATA%\Notepad++\plugins\Config" directory and suddenly everything seems to work.

    Doubtless this would have been obvious to you afficionados, but I felt quite pleased with myself and decided I should broadcast the information in case someone else has the same struggle. I guess the plugin manager could do with a patch.

    BTW I am really happy that Notepad++ exists and regard it as essential to my sanity that it be installed on any PC I have to work on. Many thanks to the developers.



  • @Steve-Mullock

    You used the term “Plugin Manager” twice. Did you really mean that, or do you mean “Plugins Admin”?


Log in to reply