eseguire il lavoro



  • There is an error in your code on the photo in the first line!
    It should be written like this: <!DOCTYPE html>



  • To open your code in a browser, you need to save this html-file!



  • @Umberto-Capuano ,

    That’s a very different question than chrome’s translate told me. Sorry that I misunderstood.

    As @andrecool-68 said, you have to save the file; if it has been saved, but you’ve just made a minor change (the title bar is red/orange in your screenshot, so we know the file has been edited), when you Launch in Chrome (or equivalent), it won’t show the recent changes, but it will launch whatever was previously saved.

    Unlike what @andrecool-68 said, having the bad <!Doctype.html> instead of the correct <!DOCTYPE html> will not affect whether it launches or is visible in the browser.

    Newer versions of Notepad++ have **View > View Current File In … > ** (I think it would be your Visualizza menu) as the preferred method for launching in your browser.

    A couple of questions for you:

    • What version of Notepad++ are you using? You can look in the ? menu, click on Debug Info (or whatever the Italian for that is), and paste that – either as an image, or copy the text and paste it here
      fd025923-7abf-417e-8669-786804fdc4cf-image.png
    • When you say “it doesn’t make me see the page on any browser”, does that mean it opens a file in the browser, but it shows up empty? or it doesn’t even try to open the file.
    • If your Notepad++ is not new enough to have the **View > View Current File In … ** version, you should show us the contents of your shortcuts.xml file: do File > Open, and type %AppData%\Notepad++\shortcuts.xml to open that file. Then grab the contents and paste them here.


  • the browser sometimes doesn’t even try to open the file and sometimes opens it but it does show me commands without showing the program, the shortcurt is:<NotepadPlus>
    <InternalCommands />
    <Macros>
    <Macro name=“Trim Trailing Space and Save” Ctrl=“no” Alt=“yes” Shift=“yes” Key=“83”>
    <Action type=“2” message=“0” wParam=“42024” lParam=“0” sParam="" />
    <Action type=“2” message=“0” wParam=“41006” lParam=“0” sParam="" />
    </Macro>
    </Macros>
    <UserDefinedCommands>
    <Command name=“Get PHP help” Ctrl=“no” Alt=“yes” Shift=“no” Key=“112”>http://www.php.net/$(CURRENT_WORD)</Command>
    <Command name=“Wikipedia Search” Ctrl=“no” Alt=“yes” Shift=“no” Key=“114”>https://en.wikipedia.org/wiki/Special:Search?search=$(CURRENT_WORD)</Command>
    <Command name=“Open file in another instance” Ctrl=“yes” Alt=“yes” Shift=“yes” Key=“117”>$(NPP_FULL_FILE_PATH) $(CURRENT_WORD) -nosession -multiInst</Command>
    <Command name=“Lunch in IE” Ctrl=“yes” Alt=“yes” Shift=“yes” Key=“49”>Lunch in IE</Command>
    <Command name=“Lunch in Chrome” Ctrl=“yes” Alt=“yes” Shift=“yes” Key=“65”>“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”</Command>
    </UserDefinedCommands>
    <PluginCommands />
    <ScintillaKeys />
    </NotepadPlus>
    informazioni di debug.png



  • @Umberto-Capuano said in eseguire il lavoro:

    <Command name=“Lunch in IE” Ctrl=“yes” Alt=“yes” Shift=“yes” Key=“49”>Lunch in IE</Command>
    <Command name=“Lunch in Chrome” Ctrl=“yes” Alt=“yes” Shift=“yes” Key=“65”>“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”</Command>

    So, two comments:

    1. “Lunch in IE” (which is what is contained in that <command>...</command> is not a valid Windows command, so it won’t run. And the chrome will only work if that’s the path to your chrome.exe.
    2. In v7.8.1, you should have the View menu entries. However, they were improved in v7.8.2; you might want to upgrade to the newest v7.8.4, and use the entries in that View > View current file in… submenu.


  • the path to chrome is that but unfortunately does not run me the file , I downloaded the latest version and it exits this now as I can fix it thanksImmagine.png



  • On new versions, a new option for opening files in the browser is added:

    Imgur



  • thank you so much



  • Note that these commands are not enabled in @andrecool-68 's screenshot because his active file is new 1 , which is an “unsaved” file. The commands can’t run on an unsaved file because, outside of Notepad++ (e.g. in a browser-running command line), the name “new 1” has no meaning. If the active file had been a real, named and saved file, the commands would have appeared enabled.



  • Now I have another problem no matter how much you save the file in html on the browser where I run it exit the scripts without letting me see the content (sorry for English)


Log in to reply